without ‘www’ → DNS_PROBE_POSSIBLE error
with ‘www’ on domain → it is working fine.
website hosted on gcp ( bucket ), it is not catching root record by itself and I don’t know how to add manually.

  • bucket name is mydomain.com without www

  • When I added domain to cloudflare it only received two dns CNAME records for _domainconnect and www (No CNAME or A record was received for root domain or @)

  • I have also tried page rules where I tried forwarding URL page rule from mydomain.com to www.mydomain.com

I am using GCP Cloud Storage buckets as a sub-domain like cdn.mydomain.com or static.mydomain.com.

I remember few topics about using it for root domain.
I am not sure for a case where we use root (naked) domain + wanting www, but I think we have to have two buckets? with names configured as


Which might have sense, but duplicated files right?

Nevertheless, may I ask you what kind of DNS records have you got at the DNS tab of Cloudflare dashboard?
Have you got both of the records added?

Furthermore, have you tried using Page Rules to configure redirection from www to non-www as follows from below?

Hello! I have explained it further in original post itself. Kindly check it. Thank you :slightly_smiling_face: