DNS_PROBE_FINISHED_NXDOMAIN with selfhosted domain

Hi, I’ve been user of Cloudflare for a while but I’m having a trouble now, I explain my situation.

I have a domain (that is in fact registered though Cloudflare domains) that was pointing to a site in a hosting. As I’m moving to another hosting (Siteground) I can’t seem to make the site work and I’m lost between the 2 interfaces. I tried deleting the configuration from Cloudflare and start from scratch but without any success.

It seems to be a DNS_PROBE_FINISHED_NXDOMAIN error and I think that maybe I should add manually some DNS records? But I don’t get why with other sites I own these DNS are automatically added and precisely this domain that is hosted with Cloudflare seems to be more problematic.

URL is bilbolos.com

Any ideas?

Thats correct. this error occurs, when you do not have any DNS entry for bilbolos.com. Please point your domain to the hostingprovider of your choice.

It’s because you moved the domain to Cloudflare, one of the steps is to scann the domain at the current registrar for existing DNS entries and automatically add them, if there are any to be found.

Thanks but still don’t get it. So, you are saying if my site is on Siteground and domain on Godaddy (for example) the domains are added automatically but if the domain is on Cloudflare, all the DNS (A, CNAME, MX, etc) need to be enter manually? I think there must be something I’m not doing right.

Any tips or manual to put all the DNS manually?
I’m not an expert as you can see and I get lost in these things. I liked from Clouflare that was always so easy to set up in my experience.

Nope. When you add a domain to Cloudflare for the first time Cloudflare adds all DNS entries to the DNS section automatically. When you delete them they are gone. Then you need to re-add them manually.

Of course: https://support.cloudflare.com/hc/articles/360019093151

I think what you have deleted are your DNS entries. Thats why you need to re-add them manually. But I can just assume, since I don’t really know what you have done.

1 Like

I really deleted the whole domain from Cloudflare (not the DNS records) since I thought it was easier to start from scratch than make manual adjustments since I had moved the site to another server.
But it was added this second time (and a third one, of course I tried again) completely blank, without any DNS entry.

I never heard of that. But if that happened like this, then feel free to manually add the wanted DNS entries to the DNS section.

Readding the domain ofc does not make sense, which there are no public DNS entries which Cloudflare could detect.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.