DNS_PROBE_FINISHED_NXDOMAIN error with Google Site

I’ve transferred my domain: mikefishceramics.co.uk to Cloudflare and am trying to direct to my Google Site. I’m getting the browser error: DNS_PROBE_FINISHED_NXDOMAIN.

There’s no DNS record for mikefishceramics.co.uk, there is one for www.mikefishceramics.co.uk
https://cf.sjr.org.uk/tools/check?62301cc571cd4974935d78fcd1f56a9b#dns

You need to add a DNS record for your apex domain and also set your SSL/TLS setting to “Full (Strict)” to prevent the “too many redirects” currently happening for www.
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

Thanks. I’ve added a CNAME record using @ in the ‘name’ field and the target as Google suggested: ghs.googlehosted.com. (not sure if that was the right thing to do).
I’ve set to Full (Strict).
I’m now getting a page saying ‘SSL Handshake Failed’.

There’s likely an issue with the origin certificate on your Google site. Set the @ and www DNS records to “DNS only” to see the certificate (and to allow Google to validate the DNS and then generate the certificate if needed).

How do I do that please?

For each of the DNS records, press “edit”, change the “proxy status” switch so it goes from orange (proxied) to grey (DNS only), then press “save”.

Thanks, I’ve done that. Browser is now returning: ERR_CONNECTION_CLOSED.
What’s the next step please?

I don’t use Google sites, but I guess you either need to wait for the SSL certificate to be generated, or set it up yourself. Best to check with Google.

I can’t see any options in Google to view or make any changes to SSL certificate. Do I need to wait for something to happen and then set back to proxied?

As I say, I don’t use Google Sites, but looking around it seems SSL should be provisioned automatically for custom domains added. Have you done this?

The error DNS_PROBE_FINISHED_NXDOMAIN indicates a DNS resolution problem. To fix this:

  1. Check and update DNS records in Cloudflare to point your domain to your Google Site.
  2. Ensure Cloudflare’s nameservers are set for your domain.
  3. Allow time for DNS changes to propagate (up to 24 hours).
  4. Verify domain transfer status and Google Site configuration.
  5. Clear browser cache and test DNS resolution using online tools if needed.

If issues persist, contact Cloudflare support or your domain registrar for assistance.

Having left the DNS records to ‘DNS only’ for a while, I’m still not getting anything. I’ve looked at my sites SSL certificate, which looks good. Currently, my browser is returning a 404 error: ‘The requested URL was not found on this server.’

The records are still proxied, not set to “DNS only”…
https://cf.sjr.org.uk/tools/check?fd3080aa743545ce8011c9e171228027#dns

The 404 error is coming from Google, so they currently aren’t answering for your domain for some reason. You’ll need to resolve that at Google (it may work after you have set the domain to “DNS only” and they have validated the CNAME is in place).
The SSL certificate at Google works for www.mikefishceramics.co.uk but not for mikefishceramics.co.uk.

I seem to have progress, in that www.mikefishceramics.co.uk is now working, but mikefishceramics.co.uk returns ERR_CONNECTION_CLOSED.
Is the problem still around the SSL certificate on Google?
Do I leave the settings on ‘DSN only’ indefinately?

You can redirect mikefishceramics.co.uk to www.mikefishceramics.co.uk using Cloudflare if easier than trying to get Google to work for the domain.

Create a redirect rule here…
https://dash.cloudflare.com/?to=/:account/:zone/rules/redirect-rules

Copy this example exactly, just changing the host names…

Then change the DNS record for @ to a proxied dummy value of A 192.0.2.1 or AAAA 100::

You can leave www.mikefishceramics.co.uk as DNS only.

Excellent! That’s all working now, thank you.

I’m not sure about the dummy value, but I just switched back to proxied.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.