DNS_PROBE_FINISHED_NXDOMAIN error for Clouldflare ZeroTrust tunnels

I purchased the domain solarisai[dot]com from GoDadday and then changed nameservers to Cloudflare recently. The transfer was successful and I received an email from Cloudflare saying solarisai.com is active in Cloudflare. Thereafter, I tried to create a tunnel in ZeroTrust with Cloudflared on a Windows x64 bit machine for testing purposes. I tried with the public hostname test.solarisai.com that points to my local host which is http://localhost/ or http://127.0.0.1/. However, the public hostname does not seems to redirect to localhost and instead gives a DNS_PROBE_FINISHED_NXDOMAIN error.

Any help on fixing this issue will be greatly appreciated.

Thanks in advance.

Note: One thing that I missed while changing nameservers to Cloudflare was that I did not disable `DNSSEC at the registrar (GoDaddy).

How did you create the tunnel, was it via config file or remotely? The step of setting the DNS record might have been missed. If it is missing, then follow DNS record · Cloudflare Zero Trust docs

Thanks for your reply. I created the tunnel remotely. Just one more thing to clarify, do I need to create a DNS record for the subdomain, for example, test.solarisai.com? I’m assuming that the DNS record will be automatically added to the list of DNS records after creating the tunnel.

It should be created for each public hostname you create.

Thanks @Cyb3r-Jak3 for your reply.

  • Below are some screenshots of the configuration and status of the channel.

However, the tunnel does not redirect to localhost yet.

Any help would be appreciated.

Thanks.

  • Below is a screenshot of the DNS records.

  • Below is the snapshot of Windows services http://localhost/ or http://127.0.0.1/ page.

However, still getting the same error message: DNS_PROBE_FINISHED_NXDOMAIN.

Oh fun multiple threads. Anyway… the host resolves elsewhere so it’s something not Cloudflare related to resolve.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.