DNS_PROBE_FINISHED_NXDOMAIN anek.gr

Hello! I receive DNS_PROBE_FINISHED_NXDOMAIN error when I try to access anek.gr
I am using the built-in Cloudflare DNS in Google Chrome (mobile) and chromium edge (desktop).
As soon as I disable the DNS over https via Cloudflare, in the browser settings, the website is accessible. I have only issue with that particular site. Every site I generally use doesn’t have any issue (and I already use this option, since the release of it, in chromium security settings).

I attached that if it helps understanding the issue at all
https://1.1.1.1/help?_gl=11y8p1r1_gaMTA2NzQzNTI4OC4xNjQzOTcwODk2_gid*MTg3OTMyNDU4My4xNjQzOTcwODk2#eyJpc0NmIjoiTm8iLCJpc0RvdCI6Ik5vIiwiaXNEb2giOiJObyIsInJlc29sdmVySXAtMS4xLjEuMSI6IlllcyIsInJlc29sdmVySXAtMS4wLjAuMSI6IlllcyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjExMTEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMDAxIjoiWWVzIiwiZGF0YWNlbnRlckxvY2F0aW9uIjoiRlJBIiwiaXNXYXJwIjoiTm8iLCJpc3BOYW1lIjoiQ2xvdWRmbGFyZSIsImlzcEFzbiI6IjEzMzM1In0=

The site works fine on Cloudflare. The only problem I see is that anek.gr doesn’t exist on the internet and their website only works on www.anek.gr. Try that domain on Cloudflare.

1 Like

Clearly shown in the video as soon as I disable Cloudflare altogether it works. And when it’s enabled it doesn’t. What do you think might really be the issue? (Ignore the fact I’m using cellular data it does exactly the same via my home’s connection)

Greetings @user22439 ,

I am sorry to hear you are experiencing an issue with your domain.

Firstly, I noticed your domain anek.gr isn’t using Cloudflare nameservers, therefore you should check with your hosting provider to add the missing @ (anek.gr) record into the DNS:

;QUESTION
anek.gr. IN NS
;ANSWER
anek.gr. 21600 IN NS ns2.otenet.gr.
anek.gr. 21600 IN NS ns1.otenet.gr.

Regarding above stated error, kindly may I suggest looking into below article for more information about why this error happens and how to trobleshoot it:

If you are using Cloudflare nameserver, then kindly follow below instructions (even I’ve added it in screenshots as an example):

May I ask have you checked under the DNS tab at Cloudflare Dashboard for your domain name if there is an existing A anek.gr or maybe a CNAME anek.gr hostname?

I checked using online tool and a DIG command, and unfortunately I cannot found any of the A anek.gr or a CNAME anek.gr record configured.

You can add the missing @ (also anek.gr ) using below tutorial:

If so, redirect any request from anek.gr to www.anek.gr using a Page Rule and tutorial from below (good for the SEO):

Kindly, the steps from my above post would be:

  1. Navigate to the DNS tab
  2. Add another DNS entry as CNAME for @ (this is the same as your root domain anek.gr ) that looks like the www one and make sure it’s proxied and set to :orange:.
  3. After this, navigate to the Page Rules tab and create one to:

Match first input field to the anek.gr/*
and add a Setting for Forwarding URL (301)
enter the https://www.anek.gr/$1 in the input field

In picture, should look like below:

Unfortunately this domain isn’t mine. Thanks for your info! But I didn’t know that every single domain has to do those steps so Cloudflare DNS would work with them. I believe there is nothing I can do since the domain isn’t mine. I’m just an end user. Again thanks for your precious time!

I tried from a Greece location and I am unable to reproduce the issue on Cloudflare. The domain www.anek.gr resolves fine. Can you provide a DiG output? Like this:

dig www.anek.gr @1.1.1.1

; <<>> DiG 9.16.25 <<>> www.anek.gr @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58714
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;www.anek.gr.			IN	A

;; ANSWER SECTION:
www.anek.gr.		30	IN	A	212.205.13.103

;; Query time: 111 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Fri Feb 04 17:49:04 CET 2022
;; MSG SIZE  rcvd: 56

I just noticed that it only happens in chromium browsers. I used firefox in linux and even anek.gr resolved fine!
Here is my dig output:
[email protected]:~$ dig www.anek.gr @1.1.1.1

; <<>> DiG 9.16.1-Ubuntu <<>> www.anek.gr @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29517
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;www.anek.gr. IN A

;; ANSWER SECTION:
www.anek.gr. 30 IN A 195.167.86.107

;; Query time: 615 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Δευ Φεβ 07 10:21:57 EET 2022
;; MSG SIZE rcvd: 56

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.