DNS points to prohibited IP 1000 error

Not sure why out of the blue today I am getting this error as I haven’t gotten it before today. I am using cloudflare because the service I use to host my photography site has recently set it up to use two A records along with AAAA records but I am using yahoo business for my domain.

This is how I have cloudflare set up

This is the error message when one attempts to load my website:

As you notice I do not have the IP pointing to any on cloudflare. Any help in attempting to figure this out would be appreciated.

Kindly, could you please re-check with the steps as follows in the below article?:

Due to the Yahoo e-mail service, I believe the needed record should be :grey: due to this article below:

Thanks for the assistance. I have looked over the tutorial and not seeing where there is an issue with the DNS settings as is and I currently am not having any issues with sending nor receiving emails.

The issue here are the IPs belonging to a service already on Cloudflare.

Based on the Zenfolio guide, looks like that’s what is needed here:

https://test-support.zenfolio.com/s/article/407986-pointing-a-custom-domain-to-zenfolio-using-an-a-record-cname-record

Typically, some SaaS providers will tell you to set the records in DNS Only mode, but I see that it still fails that way for me when I test. Does it fail for you as well if you set all the Zenfolio records to DNS Only?

I recommend going through the Zenfolio setup steps once again, if all still fails, contact Zenfolio support to see if they can provide further insight as to why this is happening.

1 Like

Thanks for giving some advice on this issue. This all started yesterday and I have set up everything in the beginning and up until yesterday everything was working as it should.

Perhaps I am missing where to change the DNS settings to DNS Only. Where would I change that option as it is not showing that I can change it from Proxiy to DNS Only. Thanks again for your help.

I contacted Zenfolio help last night but I haven’t received an answer back from them on this issue. If all else fells I may have to temp suspend Cloudflare and set the Name servers back to Yahoo so at least my site will load up for visitors.

If you click on a record in your Cloudflare DNS, you will see the option under proxy status that allows you to flip between orange (proxy) or grey (dns only).

2 Likes

Okay I just now figured out to change it to DNS only. Will try that and see what happens.

Nice site you got there!

Thank you that seems to have worked. I have changed anything associated with Zenfolio to the DNS Only and that seems to have solved the issue. Still puzzled as to why out of the blue the settings as they were and have been from the beginning ended up not working.

Again thank you for your help.

Thank you blas.

My pleasure, glad to see it’s working now. :smile:

Hard to say, but seems like something in the way Zenfolio connects with other Cloudflare zones must have changed recently. Hopefully, they will update their configuration guide so as to make it easier for the setup.

Hard to say, but seems like something in the way Zenfolio connects with other Cloudflare zones must have changed recently. Hopefully, they will update their configuration guide so as to make it easier for the setup.

That might just be the case… I still haven’t heard back from them as to what the problem could be so might send them another message about the issue and what solved it. Well solved it on Cloudflare but wondering as you if they changed something to cause the problem to occur.

1 Like

Dropping this here for future reference,

Seems this common cause of error 1000 was at fault

  • Your Cloudflare DNS A or CNAME record references another reverse proxy (such as an nginx web server that uses the proxy_pass function) that then proxies the request to Cloudflare a second time.

Solution - Click the :orange: CNAME www to turn it :grey:

1 Like

I’ve the same problem today. @jtwilson37209 it seems Zenfolio are changing their CNAME and IP addresses next week. I guess they are preparing. The old CNAME and IP address will no longer work.

@blas Would you know why these sites will not work with the cloudflare proxy on (orange cloud). Mine will only work using DNS and the orange cloud off. Is that because Zenfolio are already using Cloudflare so it’s pointless for us to do the same?

Is this what happens also if we transfer a site to a new cloudflare account and the DNS records passed thru were proxied? Unfortunately this happened for a site that has been extremely neglected by previous web developer/cloudflare account holder. Getting prohibited IP 1000 error and hope that transfer can be reverted once completed. What can be done at this point?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.