DNS pointing to old IP host


Changed A record and still pointing to old host.

Contacted Digital Ocean to release my domain and they don’t even know what I’m talking about.

Contacted Cloudflare and they don’t even care because I’m a free customer, so I’m here on a community forum.

Even tried to liberate my domain myself following this article, Troubleshooting Custom Hostnames / Cloudflare for SaaS when moving provider

It said my domain is liberated but same issue.

My new hosting works, can see it from ip but when Cloudflare does it’s proxy it points to old host. Turn off the proxy and site is available, but no SSL and optimising.

Has anyone actually got through this issue with Digital Ocean?

Digital Ocean’s response shows they do not know what I’m talking about.

Thank you for the follow-up mail and for sharing these details.

Kindly note that we are not holding any website or domain from the connection to Cloudflare. Would you please share with us more context on "The proxy is pointing to your IP" and share with us details on how you are observing this?

I hope this helps! Please don’t hesitate to let us know if you need anything else or have any other questions. We are always happy to help!

None of those steps work because no one on either side will help.

I liberated my domain and still have the same issue.

This feels like something that Cloudflare should be able to override for even free customers, because this is harmful and unexpected.

My host Digital Ocean tells me they are not holding my domain, I know Cloudflare’s proxy is pointing to them still.

My only solution seems I’ll have to leave Cloudflare, which does not matter to them since I’m a free customer.

Never had an issue like this before where everything is hidden and everyone is in the dark. The proxy is great until it does not work correctly and then it’s like a black box.

If Liberate the Hostname did not work and you did that for all hostnames (likely roott and www) then the issue is probably not related to Cloudflare for SaaS. You should check your account for any configuration rules, Workers etc. that may be affecting this.

I’m not using any workers, the proxy points to my old IP and I cannot prove it because it’s a proxy. My Digital Ocean server has now been deleted so switching on the proxy causes a 500 Cloudflare server error.

I’ve turned off Cloudflare and I’m looking for another solution because no one can help me.

The SaaS issue would not usually result in a 500.

Can you post a screenshot of the 500 error you get? Also the URL and RayID if possible.

This is the error, it only happened after I deleted my Digital Ocean app.

My new host is working fine when I switch off the proxy or visit via my new IP.

This is a public space and I don’t feel comfortable sharing my domain.

OK, that’s not a 500 Cloudflare error, it’s a 521.

A 521 error happens when Cloudflare is unable to make a TCP connection to your origin server. Review the suggestions in this Community Tip for Quick Fix Ideas.

It’s likely that connections are being blocked to the new server.

It’s pointing to the old Digital Ocean the app and that has been deleted so it’s giving a 521. I saw it with my own eyes… the proxy never switched to my new host.

I’ll look into your reply more.

For about 6 hours yesterday both https was pointing to old server and http pointing to new server.

After I delete old server this is the error, this is why it looks to me the proxy never updated to new IP

if you are seeing your old site switch this to Flexible, you will find it under SSL/TLS > Overview in the side menu for your website.

1 Like

I won’t be sticking with flexible, but at-least my website is working.

My theory is Cloudflare won’t detach from your old host until you make your new host compatible with SSL, opening correct port as suggested by domjh.

This means if you change your A record and the DNS for SSL does not change to your new host, switch to flexible SSL and then fix your new server.

This is not correct and has nothing to do with your previous host. The new server was simply misconfigured as I said.

Then why did Cloudflare SSL proxy point to my old IP and I’m running HTTPS on old host and HTTP for new host, 2 websites running at once?

The second I deleted my old host the 521 error above shows up, this means the proxy even now is pointing to my old host still.

This is what happened, you might be wrong. I would love a Cloudflare engineer to give us the answer.

Yes, I might be. However I have seen hundreds of cases like this before so from the information you provided I can be fairly confident in what I said.

If it was the SaaS issue that you say where a hostname gets stuck, clanging SSL modes would not fix it. If it’s working over HTTP and not over HTTPS but both proxied through Cloudflare then it will be a server misconfiguration.

I understand @epic.network and @domjh already clarified it anyhow, but just to emphasise, with the change you made you dropped all encryption and have an insecure site now.

Here is what happened.

  • Change A record to point to new host
  • HTTP works and shows new host ’
  • HTTPS points to old host
  • I delete old host
  • 521 error above shows up instantly

This to me this means it’s still even now proxied to my old host which has been deleted. This makes me think the proxy will not switch until I fix my current server.

I read cases on here and I tried things on here. Maybe it’s better to say switch to flexible and see if that works and then try and fix the actual issue, because when your website goes offline for 6 hours panic sets in.

I thank you for your help and I have no doubt of your skills, I’m just saying what happend to me.

Switching encryption mode never fixes anything, that should always stay on Full Strict. The server will need fixing.

My website is running in SSL because I switched to flexible and this affords me time to fix the server and have my site running.