DNS over TLS Does not work?


#1

It used to work before and I get no love :frowning:

https://1.1.1.1/help#eyJpc0NmIjoiTm8iLCJpc0RvdCI6Ik5vIiwiaXNEb2giOiJObyIsInJlc29sdmVySXAtMS4xLjEuMSI6IlllcyIsInJlc29sdmVySXAtMS4wLjAuMSI6IlllcyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjExMTEiOiJObyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjEwMDEiOiJObyIsImRhdGFjZW50ZXJMb2NhdGlvbiI6IlNKQyIsImlzcE5hbWUiOiJDbG91ZGZsYXJlIiwiaXNwQXNuIjoiMTMzMzUifQ==

I used pfsense router latest version

Thx


#2

How did you configure it?


#3

Enabled in the resolver Forwarding Mode and Use SSL/TLS for outgoing DNS Queries to Forwarding Servers and defined DNS servers as 1.1.1.1 and 1.0.0.1


#4

What would the following command return?

nslookup -class=chaos -type=txt id.server

It might an issue with your router though. I’d contact the manufacturer in this case.


#5

I’m using DNS over TLS on iOS and it’s working.

@sandro, what should show from that command? On my Mac which uses 1.1.1.1 over Port 53 (no HTTPS or TLS), here’s what I get:

iRetina:~ scott$ nslookup -class=chaos -type=txt id.server
Server: 1.1.1.1
Address: 1.1.1.1#53
Non-authoritative answer:
id.server text = “LAX”
Authoritative answers can be found from:


#6

nslookup -class=chaos -type=txt id.server
Server: 127.0.0.1
Address: 127.0.0.1#53

** server can’t find id.server: REFUSED


#7

Why do you suspect h/w issue ?


#8

The location of the datacentre. It is the DNS equivalent of /cdn-cgi/trace.

I dont. I suspect it to be either a proper software issue or a misconfiguration. My primary advice was to contact the manufacturer (or a related community) as they will be better able to tell what the issue might be than the Cloudflare community.


#9

I don’t understand if this not the right place for 1.1.1.1 issues? and test page https://1.1.1.1/help ?


#10

It is the right place, but the issue does not appear to be with the DNS service in this case but rather your setup/router.


#11

what do you see wrong with my setup ? and how do you troubleshoot that it’s not DNS service ?


#12

Well, your setup does not appear to contact Cloudflare in the first place.


#13

how about this log https://snag.gy/zh3Lqd.jpg


#14

I am not sure what that log is saying but it would appear as if there was one successful request to Cloudflare and one failed.

Maybe if you can post screenshots of your settings someone familiar with your software might be able to help.


#15

sure:


#16

127.0.0.1 Is your Computer itself. Do you have some windows program set up thats supposed to do DoH?

Either way, your computer is not contacting your router’s DNS. This may be caused by some antivirus software.


#17

All clients on my network asking for unbound on port 53 going thru localhost, here is NAT rule (if you watch pfsense setup steps that’s what is recommended):

DNS is defensively resolving and contacting servers. the question is why 1.1.1.1/help does not show it?


#18

To prove the point:

nslookup

cludflare.com
Server: 127.0.1.1
Address: 127.0.1.1#53

Non-authoritative answer:
Name: cludflare.com
Address: 185.53.178.6


#19

unfortunately can’t keep using 1.1.1.1 until all issues resolved :frowning: