[DNS] Orange Cloudflare cloud pointing to wrong record

Hi there,
I’m trying to get docs.mydomain.com to point to docs.mydomain.workers.dev. The worker only returns a raw HTML response.

  1. I created an identical CNAME record for both docs-old.mydomain.com and docs.mydomain.com to point to docs.mydomain.workers.dev.
  2. I set up identical worker routes to my worker for both subdomains

The difference is, docs-old.mydomain.com works as expected, while docs.mydomain.com points to mydomain.gitbook.io/latest. There are no other records related to these subdomains. Initially, I thought the problem might be with the gitbook setup, so I nuked it. Now, the subdomain points to a dead URL. There is no mention of docs.mydomain.com anywhere in the gitbook configuration.

This problem only occurs when I have the orange cloud turned on for the docs.mydomain.com (The type of the record doesn’t matter, it malfunctions on A, AAAA, and CNAME). I am able to use the grey cloud (DNS only), and then the DNS records work properly, but then I can’t use Cloudflare features with the subdomain, of course.

I tried purging the cache for that particular URL, but no dice.
Does anyone have an idea what might be happening?

Update: I forgot to mention, I don’t have a Cloudflare rule that would interfere with any of the subdomains in question. The only rule I have is enforcing https.

Update: Purging everything (all cache) for the whole domain also doesn’t help. I tried flushing the cache with the Google flush DNS tool for the main domain and the subdomain, but that too didn’t help.

Hi @mislav.vuletic,

That sounds right, Gitbook use Cloudflare and may have taken control of the hostname. Are you able to contact them and ask them to purge their Cloudflare setup for your domain? Some providers don’t do that automatically when you move away, unfortunately.

Thanks for the reply. I found this ticket: DNS subdomain no longer works nor redirects to anything - #7 by jose.aguinaga

This explains a lot. I reached out to gitbook and will post an update when we get a reply. I find this practice of giving hosting providers any control of user domains very weird, I must admit.

We successfully managed to get control of our domain again. It was indeed an issue with GitBook not deleting our domain from their DNS Zone. I’m not sure if GitBook practices are at fault at this point, or Cloudflare gives too many permissions to their Enterprise users to have priority with Cloudflare services over the domain holders. I would like to see official documentation on the priority of Cloudflare services and what order does the actual pipeline resolve in. I found many instances of this problem plaguing users and I would like this to be addressed somewhere in the Cloudflare documentation.

I’m glad you managed to get it sorted. I think the partners are supposed to remove the config when you are no longer using them, but I agree that Cloudflare could do better in helping people get control back.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.