DNS only working when not proxying


I migrated my server (vrbrits dot com) from hostigators to digitalocean, the domain for this is registered with 123-reg.

I decided to set the site up on cloudlare, to point to my server (works fine with 3 other servers configured the same way)

DNS on the registrar (123-reg) is pointing to the correct nameservers (darl & tiffany) a whois shows the change has taken affect.

A ping from my local machine to the domain name resolves to a Cloudflare owned IP address.

All good up till this point :slight_smile:

If I have proxying OFF then DNS works, it shows me my new server.
If I have proxying ON then DNS is seemingly ignrored as it is caching from the old server. (I have tried clearing the cache but to no avail)

are there any diagnostic tools within Cloudflare that I can test what IP it is using when proxying? as it definitely isn’t following the settings within my DNS panel.

I tried fully removing the site and re-adding but with no luck.

Sounds like the old provider may still have a Custom Hostname associated with the domain.

I recommend reading through this:


Thank you so much, that’s exactly what I suspected the problem was (hostigator using Cloudflare) but had no idea how to fix, I used the liberate tool and now its working, thank you again!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.