DNS Only records

Hello, I just setup my domain (http://myoutdoorscout.com/) on Bluehost and created a Cloudflare account. I’ve pointed the nameserver to Cloudflare but my website still isn’t showing that my SSL is working. I’ve set the SSL settings to Always/Auto HTTPS. I’ve also followed the tutorial for setting up a www redirect page based on other community research. The DNS manager shows the MX record with a warning that the IP is exposed, but I have no idea how to fix it. I would really appreciate some input on how to solve this!

Thank you

Looks like it’s working now

In this case it’s normal/expected that your ip is exposed, as you can’t proxy mail/mx traffic through Cloudflare, so that traffic needs to go directly to your mail server.

Thank you @arunesh90 for the quick response. It’s encouraging that you are seeing the SSL working properly, but I’m not seeing it on my end. I’ve cleared my browser cache but still no luck. Why might that be?
image

http://myoutdoorscout.com/ is not the same as https://myoutdoorscout.com/.

You do not have a redirection from HTTP to HTTPS :slight_smile:

Moreover, I got your IP instad of the Cloudflare one. Which means that domain is using Cloudflare’s name servers, but it doesn’t look like the DNS entries for those hostnames (A records) are set to :orange:. They need to be :orange: to work.

As for redirecting HTTP to HTTPS just use the Always Use HTTPS setting you have.
This is not working because currently your DNS is obviously :grey:, when you go to the DNS tab, you will see a list of records. The A record with the name myoutdoorscout.com currently look like to have a :grey: cloud. Click that so it turns into the :orange: cloud.

Other way is to create a Page Rule for redirection.

Moreover, if you would like also to redirect www to non-www, you could follow tutorial below:

1 Like

Thank you! Looks like it’s working now. I really appreciate it.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.