DNS-only record suddenly exhibits proxied behavior

There is a DNS-only record that existed for a long time. It was still working fine just a few hours ago.

When I realized I couldn’t connect to SSH, I checked the dns result and it was two Cloudflare IP’s. One of them is ‘’.

I rechecked the settings and it was still DNS only. Then I tried switching to proxy and then off again, no luck.

What should I do?

Case solved. Recently added AAAA parse records and set to proxy mode. When I just added it, everything was fine because the DNS cache was still there.

Turned off proxy mode for the AAAA record, then waited a while and the resolution worked.


Thanks for returning to share your findings. It is helpful and very much appreciated.

1 Like