DNS not working with godaddy hosting

Answer these questions to help the Community help you get started.

What is the domain name?
Learncodeweb

Have you searched for an answer?
Yes, i already spent more than 5 days, Subdomains are working but the main domain not working.

Please share your search results url:
add-Cloudflare-nameservers-to-my-domain
360033747991-How-To-Change-Your-Nameservers-from-GoDaddy-to-Cloudflare

*When you tested your domain using the [Cloudflare Diagnostic Center]
Just 2mints ago.

Describe the issue you are having:
Mian domain is not working while the subdomain is working fine. I want to install WP but unfortunately not able to see any change.

What error message or number are you receiving?
For wp new and old installation so many redirect. And main domain not show any thing only the GoDaddy default page.
What steps have you taken to resolve the issue?

  1. Uninstall and install the new wp. Contact GoDaddy support but they said it is on the Cloudflare end.
  2. Rename plugin folder name and then try but the issue is nothing display on main page or main website.
  3. Subdomain working find when i create only index page sometime work but today nothing work.

Was the site working with SSL prior to adding it to Cloudflare?
Yes, before it was working fine with zerossl free ssl.

What are the steps to reproduce the error:

  1. uninstall and install again the wp or setup old wp again.

Have you tried from another browser and/or incognito mode?
Yes, i tried with vpn, proxy and private window i already delete all the history and cache but still not working.

What’s SSL level in your Cloudflare dashboard

Flexible.

Try changing it strict and tell me how it goes?

Error 526

Ray ID: 739f34c3ffdd3445 • 2022-08-13 05:56:11 UTC

Invalid SSL certificate

Pause the Cloudflare on the site and see if SSL is working at your hosting

Now I can see the GoDaddy default page i think.

Future home of something quite cool.

If you’re the site owner, [log in] to launch this site

If you are a visitor, check back soon.

demo (dot) learncodeweb (dot) com
The subdomain is working but not the main domain

I suggest you use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com. The link is in the lower right corner of that page. Give it five minutes to take effect, then make sure site is working as expected with HTTPS. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

2 Likes

I tried all but unfortunately not working.

If you have paused Cloudflare and it is still not working then this is something you need to address with your hosting provider or administrator.

2 Likes

What domain provider said this is from Cloudflare side :slight_smile: actually I am stuck my domain is down and i have no idea who can i connect it with Cloudflare.

Solution Only for WP:
I fix the issue by changing few things in code and in database.
I think it is working now learncodeweb(dot)com with http and without https protocol.

  1. Comment all code of .htaccess
  2. Open DB table wp_options and change URLS siteurl & home without https.
  3. Disabled all plugins just rename the plugins dir name directly.
  4. Add rules for https in Cloudflare.

I hope this will help others.
Thank you

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.