DNS Not Working Entirely After Adding Domain From Bluehost

Ok, so I added my domain from bluehost into cloudflare to enable my https on my custom tracking links in ClickMagick (as it wouldnt work in bluehost for some reason)

And that worked perfect.

The issue is now that, after I set everything up correctly, added name servers, added the a name, turned the cloud grey and everything else I am suppose to do when activating my dns for my email…

…it won’t work.

I can’t connect any of my mail accounts to my mail server anymore.

But I can still send and receive emails from my bluehost webmail account.

But people’s emails from microsoft are bouncing still when they send it to me.

And again, when I try connecting my outlook email or my iphone email to my domain email, it won’t connect.

I don’t know if what I typed makes sense, but I know I followed everything I was told to follow my Cloudflare to do this setup and every single topic I can find on the internet and in here, seems to not work for me.

I would love if anyone could help me figure this out, as I can’t really change out of Cloudflare because all of my old tracking links in my YouTube channel of videos that are ranking won’t work if I don’t have the https enabled with the new google chrome update.

Anyways, looking forward to your help!

Thanks,
Thomas

It sounds like it’s just a mail issue. Here are some tips:

Anything for mail (except webmail) needs to be set to :grey:. You also have two “A” records for Mail.

So go through and set mail, imap, smtp, and pop to :grey:. FTP also isn’t going to work through :orange:.

1 Like

If I change it to :grey: then it says “this record exposes your origin IP”

If you want to receive email you have to expose the IP of your email server. Ideally your email server and web server would not be on the same IP address, but if you are running everything on one server you have little choice.

You also have two A records for ‘mail’. You should delete the one that says “DNS only - local IP” as you will not be able to receive email on such an IP address.

2 Likes

That is the A record that I turned :grey: that’s what it says after I do that?

In the image you posted you have two A records for ‘mail’. The first one says “DNS only - local IP”, and has neither :grey: nor :orange: beside it. You should delete that record if you want to receive email from the Internet.

The second entry should be :grey:, and not deleted.

When you go to delete it… It is turned grey. But it just says “DNS only - local IP” instead.

It depends on how well you are able to defend your origin. Ideally you would have an origin IP that is not known, and cannot be directly attacked (or even contacted except by Cloudflare). Somebody could potentially DoS your origin, and take all your services offline, or worse.

There is a support document about this question:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.