DNS not working after migrating domain to Cloudflare registrar

So i just moved my domain to cloudflare as registrar and last night got notification that domain registration has successfully moved to cloudflare. I logged into the portal and besides domain showing up as registered no dns records setting have changed or migrated from old hostgator registrar and hosting.

So i’ve adjusted A record to point to my new ip address and cname to www.mydomain.com and i went to sleep i i woke up 8 hrs later and dns resolution is still not working.

When i tries to resolve it says ip address of my site refused the connect in error message.
Also it changes to ip address in browsers address.

I was able to browse my website previously by ip when i moved my site to new hosting server.

I’m also pretty sure SSL does not work at all, i don’t think cloudflare issued new certificate to my new server, so that’s another problem.

What do i need to do to fix all of this. Thank you kindly.

Domain?

provided and edited

1 Like

The site loads fine, however it redirects to a 35 IP address which does not respond. Is that your server? If so, you need to make sure it is properly configured for HTTPS.

yes that is my ip address and server. Where do i need to configure HTTPS? Can you elaborate more on this please?

So i’ve previously logged into apache sever and configured webserver config file for my website so that’s done but not sure what you meant.

I have not setup any SSL certificate on that server as i thought cloudflare will install one upon my site migration. Also my DNS was always on cloudflare even with my old hosting company and it was working fine.

You need to enable HTTPS in your server configuration and also deploy a certificate for your domain. That could be a paid one or a free one from Lets Encrypt or Cloudflare (-> Origin certificates).

As for the actual configuration, that would be a question for StackExchange then.

Sandro this was very helpful. I did google search just now and i definitly didn’t enable https or ssl on apache or in it’s config so that makes.

One more thing. I’m confused if i should manually on apache server create let’s encrypt free ssl cert or should i let cloudflare manage that but then it that automatic or do i need also need to do this manually on apache server for cloudflare ssl certificate?

Are there any tutorials posted here on how to configure that for cloudflare ssl?

Thank you kindly again. This was very helpfull

Cloudflare cannot manage the certificate on your server. You will have to do this manually, either via Lets Encrypt or by having an Origin certificate issued by Cloudflare. Please use the search for details on how that is done.

If you dont plan to have your site accessed outside of a Cloudflare context, I’d personally go for a Cloudflare Origin certificate, as that is easier to issue and can have a longer validity, compared to the three months of LE.

Thank you. So there is also Edge Certificates on my cloudflare ssl portal tab and under edge certificates my domain name is enabled already with universal type and status active. So both edge and orgin should be enabled?

Yes, the edge certificate is for the proxies, the origin certificate for your server. Both need to be enabled.

1 Like

Ok thank you. But why doesn’t proxy work by showing my domain but instead it shows my ip address.

Because your server sends a redirect. Once you fix the certificate and the redirect you should be good to go.

Thank you. So when i view my browser’s cert for my site it now shows cloudflare orgin cert so now i know it’s pulling the cert but it’s showing my IP instead of domain name

If i force apache config file for perm redirect for it breaks the site and you can’t access at all and then i have revert back which exposes ip.It appears i’m half way there as browser is using the cert but still other half of using domian instead of ip. I’m stuck here, not sure what i’m doing wrong here?

Edit:
So apache returned that syntax is correct.
In browser in noticed images show static ip. I think i need to change that to my domain name. Maybe that is why site returns stil static ip.

Yes, you do have the certificate in place. Now you need to remove that redirect. I guess this somewhere in your Wordpress configuration, though Wordpress and Apache are beyond the scope of the forum :slight_smile:

So cert is valid and in but browser is still reporting not secure connection even thought https shows next to site name once clicked. The redirects to https are working it seems as when you click on full url it shows https so it’s https but why does still show not secure. I went into cloudflare portal and full encryption is checked but NOT strict.

sebpctech.com

P.S
BTW it wordpress website address was IP not domain which was the issue of redirect to IP. Once i plugged that in redirects to https started to work. Thank you.

At this point you have “mixed content”.

Sandro thank you very much for your help. I just fixed this as well.

It was background image linked to http. I needed to use elementor rewrite url tool to https to fix it.

Site now shows as secured.

One more thing. When page was linked to actual IP address it loaded in 1.3 secs, now that i moved it to dns resolution its shows 7.3 sec sometimes, not all the time though.

I used gtmatrix. That’s weird as with static ip there was no slow down.

That will be whenever Cloudflare doesnt have the files in its cache any more but has to fetch them from the origin. The delay in this case was CSS files and they were all cache misses. It might be that your server takes longer on certain requests.