DNS not updating / responding

the website loads perfectly fine from namecheap DNS. The moment I change the nameserver to cloudflare on namecheap and
copy all the records
proxy the 2 CNAME records @ and www, nothing is working now. its been many many hours. please help. This website midyamobi.com

Cloudflare is timing out when connecting to your site.
https://cf.sjr.org.uk/tools/check?c82190eab4374c8b82d9fd4c0684f2f4#connection-server-https

If you set your DNS records in Cloudflare to “DNS only” instead of “Proxied”, does it work?

thanks for your response.
Yes disabling proxy – both http://midyamobi.com and http://www.midyamobi.com Work.

I have enabled proxy again now to see what happens. What could be the reason for timing out when I am enabling the proxy? how do I fix this?

thanks for your response.
Yes disabling proxy – both http midyamobi dot com and http www dot midyamobi dot com Work.

I have enabled proxy again now to see what happens. What could be the reason for timing out when I am enabling the proxy? how do I fix this?

Does it work on “DNS only” for https?

Make sure you have SSL/TLS set to “Full (strict)” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

Make sure SSL is configured and working on your server and check that Cloudflare IP addresses are not blocked from ports 80 and 443.

I have configures SSL via cloudflare so I dont think I can check for https if I disable the proxy.
Yes I have set SSL/TLS to Full(strict).

how do I check this?
Make sure SSL is configured and working on your server and check that Cloudflare IP addresses are not blocked from ports 80 and 443.

the cname is set to point to this for @ record
http://midyamobi.com.s3-website.ap-south-1.amazonaws.com/

and http://www.midyamobi.com.s3-website.ap-south-1.amazonaws.com/ to www record

Your site is redirecting from HTTP to HTTPS so if you don’t have SSL on your origin it won’t work.

Using Cloudflare SSL to front an origin that doesn’t have SSL support is not recommended these days. It is an insecure legacy from a time when SSL certificates were expensive and SSL was a CPU overhead. It deceives users into believing their data is secure when it is not.

You should ensure your origin is configured to work correctly using SSL when on “DNS only”, then you can re-enable Cloudflare.

Thank you so very much. Let me try to fix this now.
I will add a cert at origin

If I change ssl/tls to flexible - should it then not work? As then I dont need an SSL certificate to the S3 origin if I am using Cloudflare as it can handle SSL termination at its edge servers, which means my origin (S3) can use HTTP, and Cloudflare will provide HTTPS to the end users? just checking for my understanging.

If you don’t want to use SSL on the origin, then set SSL/TLS to “Off” and use only HTTP.

No, Cloudflare will provide an SSL connection to your users to Cloudflare, but not from Cloudflare to your origin. Using “Flexible” will use HTTP between Cloudflare and your origin server even if users use HTTPS. You are therefore telling your users their connection and data is secure when it is not so you are deceiving them about their security.

1 Like