DNS Not connected to cloudflare, fedora

https://1.1.1.1/help#eyJpc0NmIjoiTm8iLCJpc0RvdCI6Ik5vIiwiaXNEb2giOiJObyIsInJlc29sdmVySXAtMS4xLjEuMSI6IlllcyIsInJlc29sdmVySXAtMS4wLjAuMSI6IlllcyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjExMTEiOiJObyIsInJlc29sdmVySXAtMjYwNjo0NzAwOjQ3MDA6OjEwMDEiOiJObyIsImRhdGFjZW50ZXJMb2NhdGlvbiI6IkNHSyIsImlzV2FycCI6Ik5vIiwiaXNwTmFtZSI6IkZpcnN0TWVkaWEiLCJpc3BBc24iOiIyMzcwMCJ9

so I moved from windows to Linux Nobara, a fedora fork. I followed the instructions in the web, and still couldnt connect to Cloudflare (using 1.1.1.1 help).

then I tried to test it using resolvectl status

Global
       Protocols: LLMNR=resolve -mDNS -DNSOverTLS DNSSEC=no/unsupported
resolv.conf mode: stub

Link 2 (eno1)
Current Scopes: none
     Protocols: -DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported

Link 3 (wlo1)
    Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
         Protocols: +DefaultRoute +LLMNR -mDNS -DNSOverTLS DNSSEC=no/unsupported
Current DNS Server: 1.1.1.1
       DNS Servers: 1.1.1.1 2606:4700:4700::1111

that confused me even further, so I changed dns directly to

sudo nano /etc/systemd/resolved.conf

that also did nothing.

i restarted the laptop, systemd-resolved, and the wifi. still no good…

It works on windows and android, i also tried on ubuntu and it worked. not sure about this one

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.