DNS - new CNAME not working - 404 Error!

#CommunityTip
Seeing Error 404 for my URL…because of something wrong with the CNAME…

Hi!

I need to have another CNAME for my site:
www.courses.jennyelenihealth.com
I only have the ‘https://’ working, but need the ‘www’ one as well.
It’s integrated with my thinkific site.

So, I created a new CNAME : www.courses
And then the domain (in alias of) is: jennyelenihealth.thinkific.com

But, it’s now coming up as Error 404!!!
Please help!

Thanks!!
I did this about 12 hours ago.
Cheers,
Jenny

A 404 is a problem at the server end. Your CNAME points just as you have specified. So the server isn’t recognizing the www sub-subdomain.

Plain ol’ courses is a redirect to…courses, but with a subdirectory of courses as well. It looks convoluted, but it works.

Is the server configured to recognize www.courses as a valid subdomain?

1 Like

Hi Sdayman,

that was a quick reply!
I’m not sure what you mean by the server being configured to recognise www.courses?
Is this something to do with where I am hosting my site? (its’ with littleoak.net). Do I need to check something with them?

Sorry if ignorant question…

Hi There,
I contacted my host provider. It’s not a host problem. they verified it. the 404 error only came up since I created the new CNAME record. Unless the change ist still being propagated.

My host provider adamantly confirmed and emphasised its Cloudflare.

I’m going to adamantly confirm and DOUBLE EMPHASIZE it’s them. This is a DNS-only function:

The CNAME points to thinkific. And when I try to connect to their server using your CNAME, it fails:

Considering that without the ‘www’ in front, it’s functional, would you mind if ‘www.courses’ would redirect to just ‘courses’?

If so, set the CNAME for ‘www.courses’ to :orange: (I think it’s :grey: right now), and add a Page Rule:
Match www.courses.jennyelenihealth.com/* with a Forwarding URL (code 301) to https://courses.jennyelenihealth.com/$1

p.s. If the “Host” you contacted earlier was your regular site host (Littleoak?), and they’re not Thinkific, then they can’t help. It’s an issue at the Thinkific end.

1 Like

Hi Sdayman!

Thank you so much.No wonder littleoak couldn’t help. But,they did not direct me to Thinkific. I just contacted them too. Hopefully they fix this!!!

Re: your other suggestion. I want to have the alternative options for the URLs. Of course, I don’t mind that without the www is functional. So, what your’e saying is that the www would simply redirect to the https:// site url? That could work.

Meantime, I’ll see what Thinkific do?

My personal preference is to not use ‘www’ for any URL. On top of that, Cloudflare’s default SSL won’t cover a sub-subdomain, so you can’t put ‘www’ in front of a subdomain and set it to :orange: unless you pay $10/month for the Dedicated Cert with Custom Hostnames.

So my advice is to leave it alone and just use the Page Rule to redirect.

1 Like

Ok. I see. I got a response from Thinkific.
Saying: " I noticed that you added “www” to a subdomain courses.jennyelenihealth.com. The “www” is also a subdomain so this is why www.courses.jennyelenihealth.com does not work. You can use “www.jennyelenihealth.com” (also a subdomain) but you cannot have 2 subdomains in a URL."

I’ll wait to hear for instructions as I don’t know what this all means and what I’m meant to do now anyway!

1 Like

Hi Sdayman,

so, I think I get it all now. for your interest (and your time for helping me! Thank you so much for seeing it’s Thinkific thing!) , here is what it’s about. Thinkific said: " A Subdomain can be added to jennyelenihealth.com

Examples:

courses.jennyelenihealth.com

learn.jennyelenihealth.com

www.jennyelenihealth.com

Basically, “courses” and “www” are both Subdomains of jennyelenihealth.com so you won’t be able to use www.courses.jennyelenihealth.com


So, I’m wondering that I could still do a redirect? as you suggested?

I’ve done your suggestion. Fingers crossed it works!

If not, I guess I just cannot have the www, and remember to never put that as the URL in my texts and promotions.

1 Like

Sdayman,
Thank you!!!

It worked INSTANTLY.
Just redirects now. Super fantastic!

thank you.
Saved me another day on support .
Have a great day.
~ Jenny.

1 Like

I’m glad it’s working!

There’s not a great reason to put the www in front in your promotions. It’s just extra to type, takes more space, and sends visitors to the non-www anyway.

1 Like

Yes, you’re probably right. Yep. I never thought that. A bit old-skool perhaps on my end.

:slight_smile:

1 Like

I mean, yes, you are right.:smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.