DNS long resolution delay causing slow initial page load

On both my sites which I utilize Cloudflare no matter how much I tweak the sites for fast loading using speed tests, I am getting this initial long load time. It kind of is outweighing the other benefits, and I would like to resolve the matter.

longload

It occurs both in loading my http and then during the redirect to https, and the total kills my initial load time.

I am using Wordpress, and a plugin called “Really Simple SSL” to facilitate the redirect to SSL.

I can’t say for certain that this is plugin isn’t causing the issue, but my domain register thought it didn’t have to do with my initial DNS records and may be something somehow with Cloudflare.

Any thoughts?

That doesn’t look like DNS, as the initial bars have already happened. That’s usually caused by page generation time, as WordPress creates the page dynamically.

You shouldn’t have to redirect to SSL. If your server has SSL for your site, then Cloudflare handles SSL in Crypto: “Always Use HTTPS” and “Automatic HTTPS Rewrites”.

Are you using a Page Caching plugin? That should pre-generate the page for non-logged in users.

Time to initial byte is always around 2.458s. Godaddy tech support thought it was DNS.

This is occurring exactly the same on a very optimized site with a YSlow Score (91%)

speed

Can you post the domain name?

Okay, but ignore all aspects of this particular site’s performance (especially unoptimized images, etc, these will be converted into static pages and optimized) besides this mysterious bump or hump when on connection.

(I disabled this SSL plugin but left it’s redirect, which was an option. I don’t know what the deal is but I use the SSL certificate from Cloudflare and it doesn’t show-up on wordpress without first using this plugin. As I don’t know the specifics of how this plugin writes to the the access file or how it works, possibly it could be a factor in the issue.)

—>> santa-fe.tours

As @sdayman correctly assumed, it is not a DNS issue. It is a delay coming from your webserver, which takes quite some time to send back the content, respectively even the first byte -> http://sitemeer.com/#https://santa-fe.tours (DNS is double digit milliseconds, response takes four+ seconds).

2 Likes

Okay! I will accept this as the case. It is a shared hosting account, and that likely is the issue.

In another type of test I tried on my previous Cloudflare managed site, I found that the chain of aliasing contained some extra steps. I was asking tech support today if this was also happening with this new site, and trying to trace the reason. I was wondering if an initial error with my DNS records could be inherited to Cloudflare through their initial mapping process or setup. This is when he did a standard waterfall test and suggested that maybe it was on an error with the Cloudflare settings.

I don’t offhand have a link to that previous type of test I ran, but obviously, server speed is probably more important as you suggest!

This topic was automatically closed after 30 days. New replies are no longer allowed.