DNS keeps resetting to default when connecting to internet


#1

Hello, I have recently been changing my devices’ DNS to Cloudflare’s 1.1.1.1 and 1.0.0.1. I apply it and works flawlessly. I bring my laptop (Macbook) in to work, connect to the internet and now my DNS went back to default. Happens whenever I connect to an internet.

I am decent with computers and have some knowledge in coding as a front-end web developer but I don’t have any knowledge in networking, though I have been trying to learn. I just didn’t know exactly what to search to find the answer I am seeking for, so I figured to ask here.

I also went into my router to change the DNS to the above ones so I wouldn’t have to change the DNS on every single device in the household. Once I did that, the internet stopped working completely so I had to go back to the DNS my ISP gave then it started working.

Can anybody help me out with this to always be utilizing Cloudflare’s DNS?

Thanks.


#2

I believe that each WiFi connection has its own DNS setting. You’ll have to set it for each network you join.

The router is on your home network? If you manually set a device to use 1.1.1.1, does it work? How about if you just use 1.0.0.1?


#3

Gotcha on the Wifi connection having its own DNS setting.

I inserted both 1.1.1.1 and 1.0.0.1 into my router and the internet just stopped working. I figured since it was applying the changes, the connection would be interrupted momentarily, but it never bounced back after 45 minutes of patiently waiting and finding other stuff to do. Then I switched back to the default DNS addresses and within five minutes the internet was back up and running, then I had to change the DNS on my devices once again to Cloudflare’s.


#4

Try just 1.0.0.1. Changes should be instant. But have you tried setting 1.1.1.1 or 1.0.0.1 directly on your home devices?


#5

Yes and whenever I reconnect to my internet, the devices default to the original ISP DNS and not CF’s. I will try the 1.0.0.1 only when I get home from work later.

Thank you for your quick replies.