DNS issues with notion site

Hey there! I’m trying to set up a notion website with custom domain using cloudflare. Full context is that I already had a working non-notion website at the root domain (marto.lol) and a notion site as subdomain (intro-ethereum.marto.lol). I wanted to add a new one (intro-defi.marto.lol) under a new subdomain for which I:

  • Created a new worker with its own custom script (a copy of the existing one, with modified parameters)
  • Added a new DNS record

Everything was going well until I tried to add a new A record for intro-defi, pointing towards 1.1.1.1. I tried to just copy whatever I had for intro-ethereum already, which appeared as proxied (although showed DNS only when expanded, which was a little weird). I know that cloudflare does not allow proxied records for 1.1.1.1, but that’s what it showed.

After failing to create a proxied 1.1.1.1 A record, I tried changing the existing one’s name from intro-ethereum to intro-defi just to test. That’s when I broke the existing domain :joy:

Anyway, this is my setup now:

  • Two different workers, each with its own set of routes (see below)

  • This is how my DNS records look like (I swear intro-ethereum was orange before!) (see below)

But none work. This is what I get when I run nslookup:

➜  ~ nslookup intro-defi.marto.lol
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	intro-defi.marto.lol
Address: 1.1.1.1

➜  ~ nslookup intro-ethereum.marto.lol
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	intro-ethereum.marto.lol
Address: 1.1.1.1

➜  ~ nslookup intro-defi.marto.lol 1.1.1.1
;; connection timed out; no servers could be reached

➜  ~ nslookup intro-ethereum.marto.lol 1.1.1.1
;; connection timed out; no servers could be reached

Finally, workers seem to be working (:stuck_out_tongue_winking_eye:) since they return 301 (see blow)

So bottomline, there’s something wrong with the DNS records. I tried flushing my own DNS cache as well as changing my DNS resolver to 8.8.8.8.

Any ideas?

EDIT:

So the forum doesn’t allow me to have 3 embeds on my post because I’m a new user, here’s all the screenshots.

This is now a duplicate of Issues resolving `1.1.1.1` A record for Notion site.

Yesterday I created a new topic asking for help with the DNS configuration of the notion site of a course I’m teaching and askimet (the spam prevention bot) flagged my post as spam. The course is supposed to go live tomorrow and it’s not up yet, so I’m really distressed. Sorry for being this pushy, but i’m in a hurry.

Originally the topic contained three screenshots which I wasn’t allowed to post because I’m a new user, so I ended up linking to an imgur forlder with the three images.

tl;dr sorry for insisting, all I’m asking is for a mod to review and accept my question so I can get help :pray:

Thanks and sorry

Originally this was a post asking to unflag another one, but since it appears it has been deleted, I reproduced it here:

https://community.cloudflare.com/t/please-review-my-flagged-topic/330764/5?u=martriay

I’m not a mod, but I can usually dig up flagged topics when I have a link. You wouldn’t happen to have that in your browser history, would you?

1 Like

Thanks for the prompt reply. I do but I cannot access it, maybe you can.

I’m sorry to say it appears to be completely buried.

Someone else here was using a Notion site and referred to these setup instructions (There’s a Cloudflare set of instructions there):

Thank you, will try to reproduce it. I’m aware of that post and I’ve set up notion sites in the past. The problem I’m having is with the DNS records since the workers seem to be working (:stuck_out_tongue_winking_eye:) just fine because they’re redirecting, but the resolution is working funny.

I had a working notion site on a subdomain (intro-ethereum.marto.lol) which appeared orange (proxied) but “DNS Only” when expanded – which was weird because afaik proxied shouldn’t work for 1.1.1.1 records). Since the new subdomain (intro-defi) wasn’t working, I tried changing the name of previous, working record, and then everything got broken.

I had to delete both records and create new ones, which are not proxied. The problem I’m having is that now they barely work from most computers/connections I tried but they work over mobile’s 4G – I’m assuming they’re using 1.1.1.1 as resolver?

Honestly I don’t know. This is how my records look like:

And this is what I get when I run nslookup:

➜  ~ nslookup intro-ethereum.marto.lol
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	intro-ethereum.marto.lol
Address: 1.1.1.1

➜  ~ nslookup intro-ethereum.marto.lol 1.1.1.1
;; connection timed out; no servers could be reached

➜  ~ nslookup intro-defi.marto.lol
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	intro-defi.marto.lol
Address: 1.1.1.1

➜  ~ nslookup intro-defi.marto.lol 1.1.1.1
;; connection timed out; no servers could be reached

I’m not sure that 1.1.1.1 is a good option for an IP address placeholder. Better to use 192.0.2.1

Once again, thanks for replying so fast. I’m not an expert on DNS, why is this record a placeholder and why is 192.0.2.1 better? I’m trying this right now thanks.

It’s one that Cloudflare will let you set to :orange: Proxied. A hostname needs to be Proxied in order for a Worker or Page Rule to intercept traffic for that hostname.

1 Like

Understood. And 192.0.2.1 is an cloudlfare owned IP or has anything to do with internal networking? Sorry if it’s a dumb question and thank you very much, this is working now!

It’s literally a Test IP address. It’s not private (internal) or public (external). Though it’s considered to be in a private range.

From https://rdap.arin.net/registry/ip/192.0.2.0 :

Comment: Addresses starting with “192.0.2.”, “198.51.100.”, or “203.0.113.” are reserved for use in documentation and sample configurations. They should never be used in a live network configuration. No one has permission to use these addresses on the Internet.

1 Like

Got you. And why do they need a placeholder? Because something has to be there for the A record to be set but it doesn’t matter what because the worker is redirecting it anyway?

Correct. The hostname needs to resolve in DNS so visitors can connect.

1 Like

This post was flagged by the community and is temporarily hidden.