Dns issues es with long time site

Thank you Epic, so kind of you to answer so promptly.

Sadly I use the poor mans tier as I’m still in a trial phase.

My problem at present is my website is not working. Nothing has changed in many months.

As a precaution, I deleted the domain from Cloudflare, I then went to my domain and reset the DNS. It continued not to work, so I rang my registrar/hosting company. They said Cloudflare still have DNS control and that I need to contact them.

I find this confusing, if I have deleted the domain from my Cloudflare account.

I have since re-added it, in an attempt to resolve, but I haven’t found it helpful so far.

I used the diagnostic centre facility and it said errors were found with:

  • Check DNSEC Configuration.
  • Check DS record configuration
  • Check for redirect loops
  • Check the HTTPS status
  • Check if redirecting unencrypted HTTP traffic works
  • Check the status of encrypted traffic
  • Check the site for mixed content
  • Check site speed (TTFB)

This is for a website built with html and php.

Thanks in advance and thank you very much for reading this.

I think that your issue is that your server SSL certificate has just expired. Could you disable (stop) Cloudflare and see if SSL works?

Hope it helps!

1 Like

Thanks @Lumito , I’ll give it a try! I keep thinking that I got a free SSL Cert from Cloudflare. I’ve now bought unlimited SSL’s from my registrar/hosting company, but I’m not able to apply it all the while Cloudflare is locked onto my domain :frowning:

@chrisa Hello there,

It looks like you’ve not yet updated the NS records in your domain registrar / host. When you update, that’ll be alright!

1 Like

Thanks Neil! Because I need the website to be up and running again, I’ve taken the precaution of removing the domain from Cloudflare. Just need to wait for the usual propagation, then I can have income again, which is nice :slight_smile:

I understand your trouble. Okay, if you’ve removed the site from Cloudflare. But, you’ve not removed the Cloudflare NS records from your domain registrar / host. Please check again. Fix this. Your website propagation is almost complete. Check it here:

1 Like

In the future, you will be better served by not removing Cloudflare nameservers. Doing so only adds unnecessary delays to any efforts you are undertaking to troubleshoot and restore a service disruption.

You can bypass the Cloudflare proxy and route traffic directly to your origin server in five minutes or less by simply toggling the DNS record from :orange: to :grey:. If you need to quickly bypass Cloudflare for all records in your DNS zone, you can simply Pause Cloudflare.


Thank you again Neil, I genuinely appreciate your voluntary help :+1:

I have defaulted the DNS with the registrar / host.

Here are the records, not sure if I needed to redact

Completely agree, unfortunately panic set in and I just wanted the website to work.

I did have another domain with Cloudflare, that had SSL as part of Cloudflare. I removed that from the Cloudflare account, reset the DNS to default within the registrar/hosting, provided a new SSL Cert and it was all done within 10 minutes. I don’t understand why I’m having so much trouble with an actual important domain, sods law.

Isn’t it fixed yet?

I do not see any NS records. If you’ve done that, then it should work

1 Like

Clear the browser cache files n give it a go.

1 Like

Not as yet.

I think the issue is no SSL possibly. Unfortunately when I go to my registrar/hosting and attempt to apply an SSL Cert, I get this:

Operation Incomplete

The SSL certificate can only be used for domains that are using 1&1 IONOS name servers. To set 1&1 IONOS name servers for this domain, select ‘Use 1&1 IONOS Name Servers’ in the ‘DNS Settings’ section.

I haven’t done that, but I have tried the site on different browsers and different devices. I used my mobile and mobile data and still no joy sadly.

Thank you again for persevering with me.

Please have a glance here:

You wont’ be able to fix unless you update the NS records in your registrar

1 Like

I did check that (and thank you for that), but it still doesn’t appear here (UK).

Just to clarify, the Name servers were reset around 4 hours ago. I haven’t done anything with the individual records as yet, in case I deleted/amended the wrong detail.


Is it from the same panel?

It is also possible that nameserver is taking time to update. You may have to wait for couple of hours and try!

It is indeed.

I can only assume that’s the case…or hope, rather!

I have to say, what is curious is that I have another domain with what was exactly the same config (with Cloudflare) that is running without issue.

It’s rare but it could take up to 24-48h for the nameservers to update globally.

1 Like

Yes I have had that before, like you say, it is rare.

I did try to enable DNSSEC (only available on IONOS) and it didn’t accept that and threw up an error.