DNS issues 2


#1

Hello and Happy new year everyone
I am having the same problem but even worse, My SSL is showing as active on both Safari and Chrome, and I have the SSL forced on my WP website with rapid SSL plugin, and I have deleted all my cookies and cache on all browsers from the beginning of time. still, my site is showing as un-secure.

Having done a bit of research it seems that Cloudflare is not set up right.

I asked my host what was going on, as I could not get jetpack to work, this is the answer I got.

“The issue is due to the fact that your domain is using CloudFlare’s DNS services. Please try disabling the HTTP proxy for your A records in CloudFlare and see if that fixes the issue. You can toggle the HTTP proxy using the cloud icon next to each DNS entry in the CloudFlare DNS Control Panel.”

Hmmm ok, I am not sure how to do this.

We recommend updating the 1st and 4th records that use 185.176.40.164 to 185.176.40.165.

Any help in directing me how to do this correctly would be amazing as I am new to CloudFlare, and I really do not want to mess things up any more than they are already.
Thank you very much and happy new year.


#2

If your host recommends updating the IP addresses then you should, just edit them on that page that you posted a screenshot of.


#3

Hello
Yes www.beneficoleather.com is my domain, and it is also the one showing in the screenshots.
I will give it a try but i am really not sure how to edit this, I will see if i can find a video on youtube first.
Thank you very much


#4

On that screen that the screenshots are of, just click on the IP you wish to change and you can edit it there.


#5

Ok so that did not work, I was able to edit the A as my host suggested and then deleted cookies and cache but I am still getting the

Any other ideas? as I cannot get either jetpack or my SSL to work, and I cannot edit my CSS with Stylizer7 so I am a bit stumped at the moment.

Thank you


#6

Aha! I see the issue now @user2122!

I have just had a look and your nameservers are still set to ns5.awardspace.com and ns6.awardspace.com. You appear to have added NS records for the Cloudflare nameservers but that won’t work. Cloudflare doesn’t work on NS records, it needs you to change the authoritative nameservers.

This means that, to get it working, you will need to go to your domain registrar and change the nameservers ns5.awardspace.com and ns6.awardspace.com to the Cloudflare ones. Looks like they may be gerald and zoe!


#7

I did this yesterday
I watched a video to make sure I did it right so I am very surprised
Is there something that I still need to edit ? or have I done it totally wrong?
Thank you .


#8

You will need to change the nameservers, probably in the nameservers tab on that page, adding NS records to DNS won’t allow Cloudflare so work properly.


#9

Thank you so very very much
I can now use jetpack, I have not deleted my cookies and cache yet as i am working on 3 projects at once so i have to wait for one to be done before i can delete the cookies and cache again.
I really appreciate all you help.


#10

The error has not gone yet. It appears that your A records are set to :grey: rather than :orange: but the SSL redirect on your server is kicking in. This means it is trying to redirect to HTTPS but as the record is set to :grey: it throws the SSL error and gives you an invalid cert from the server.

Also, you don’t appear to have changed the IP that your host recommended. The records in Cloudflare should match the ones at your host so the one ending in 4 needs to end in 5.

Hope this helps!


#11

Hello

I have change the Ip that was suggested.

1 and 4 as they instructed

And I activated it so that it is showing orange when I did it.
What am i missing


#12

Your site now works fine but you have a Let’s Encrypt certificate rather than a Cloudflare one… Doing a DNS lookup also returns that Cloudflare nameservers are being used but the :orange: cloud is not enabled. Try giving it a few mins to propogate… What SSL mode are you using? (Flexible/Full)


#13

I am using full
When researching about this i was told to add a lets encrypt to my woocommerce site even though i was using CloudFlare is that article wrong ?


#14

No, it is not wrong if you are using Full (which is good!). Have you definitely enabled :orange: on the A records?

Are you able to post a screenshot of the SSL box at the top of the Crypto page in Cloudflare please?


#15

Ok I will give it 24 hours again and see if it resolves

And yes I have definitely enabled the orange cloud in the A records as shown in the screenshot here.
A records 1 and 4

Thank you


#16

@user2122, Just to follow up on this, the site is all working correctly with CF SSL now.


#17

It looks like it’s all set now. I’m reaching it with HTTPS and it’s showing a Cloudflare TLS certificate.


#18

user2122, Has anyone tried these steps ??

Do they really work??
vidmate


#19

Hello

Thank you
Yes it is showing up with the https now and everything seems ok.
I do have one very big problem though, I think the settings are stopping me from styling my website.
I have been trying to edit my website style.css with stylizer7, when i go to save via ftp i can connect to my servers and save my file but when i go to my browser and delete my cookies and cache the edit i have made and saved have no effect.
I am stunned as i have never had a problem like this before and it only seems to be on this site with CloudFlare so i am wondering if CloudFlare is stopping me from saving the edits to my style.css files ?
I can change the css on all my other sites except for this one.
If CloudFlare is stopping me from styling my site due to the DNS I have a massive problem.
Any ideas ?
Thank you


#20

Could be the Cloudflare cache: