DNS issue with Minecraft server ip

Hello,

I am having an issue with Cloudflare’s DNS management. Here is how I set it up…


I am certain that I set this up correctly, however, every now and then, in Minecraft it will say “unknown hostname” which is what I do not understand. Why does it fluctuate between working and not working?

Cloudflare does not support proxying Minecraft by default, you will need to use Spectrum for that. If you want just the domain to work you will need to have it grey clouded, or add a subdomain for it and grey cloud that

1 Like

Sorry, the screenshot posted was incorrect. That was for my website. This is the right screenshot:

Is it still the same solution?

Yes I believe so, I am able to ping that subdomain

1 Like

Looks like it works

image

2 Likes

Yes, it’ll work periodically. In any random time it’ll revert to “unknown host name”, which is what I find very weird.

That could just be your ISP’s DNS servers flaking out. Have you tried switching your local DNS resolvers to something else like 1.1.1.1/1.0.0.1, or Quad9/Google DNS?

No I haven’t. Can you explain “switching your local DNS resolvers”.

https://1.1.1.1/dns/

The website gives the tutorial for local internet? What would I have to change on Cloudfare. (Sorry, I am new to all of this).

I doubt it’s a Cloudflare issue. You may want to set up a free monitor at UptimeRobot.

It actually does look like there are some issues:

https://www.whatsmydns.net/#A/play.harmonymc.net

https://www.nexcess.net/web-tools/dns-checker/#play.harmonymc.net--A

When checking with dnsviz, it failed the first time before working the second time, although with a NXDOMAIN on the hostname:

1 Like

The only reason why I think it’s a Cloudflare issue is because when I had GoDaddy manage my DNS for my minecraft server I had no issues. However, when I switched over to using Cloudflare’s nameservers the issues arose.

I am also having an issue where my store’s website (for my Minecraft server) will go down. This happens the same time when my Minecraft server says “unknown hostname”. I wonder if they are connect somehow.

Just by the looks of it, there seems to be some issue with the nameservers (or registrar) for your domain. Is the domain ‘active’ on CF (go to your domain’s overview in the Cloudflare dashboard)?

https://www.whatsmydns.net/#NS/harmonymc.net

1 Like

Yes, it is active.

image

Is DNSSEC enabled in the DNS tab? And which two Cloudflare name servers are assigned to that domain in the DNS tab?

No, DNSSEC is not enabled. The two Cloudflare nameservers that are assigned are bailey.ns.cloudflare.com and javon.ns.cloudflare.com

Ohhhhh…this can’t be good. You’ll need to make sure to only assign the Cloudflare name servers at your registrar (GoDaddy?) There is also a warning in your registration:
https://icann.org/epp#clientRenewProhibited

So only use Cloudflare’s nameservers on GoDaddy. Gotcha.

However, I have namecheap’s nameservers on GoDaddy for my website to work (harmonymc.net). How would I transfer this to Cloudflare? Lastly, should DNSSEC stay disabled?