DNS issue CNAME Record - 1000 error

Hello, I am trying to set up a custom subdomain. I have created a CNAME DNS record that points our website’s subdomain to a learnworlds domain. I have followed the steps exactly as per learnworld’s documentation of how to set up a custom domain in Cloudflare.

Below is a screenshot of the 2 records I have set up in Cloudflare. Tried changing the setting to proxy but it didn’t make any difference.

The Google Admin toolbox shows that it is working as expected, but when I try to access the new subdomain, I get a 1000 error.

Any help would be appreciated as not sure what to try to resolve this.

Many thanks
Lizzie

The subdomain I am trying to create = academy.smeclimatehub.org
The learnworlds domain (target) = sme-climate-hub-academy.getlearnworlds.com

Leanworlds uses Cloudflare so the error is telling you your CNAME resolves to a Cloudflare IP address, which it doesn’t allow. (There was someone else with similar today on Digital Ocean).

But you have set this up as this per Learnworld’s advice so I’m not sure what is happening as they expect it to work. Someone else may know.

dig +short sme-climate-hub-academy.getlearnworlds.com
cname.learnworlds.com.
cname.learnworlds.com.cdn.cloudflare.net.
104.20.246.77
104.20.247.77

Note that www.academy cannot work as that is a second level subdomain so the default Universal SSL certificate from Cloudflare which only covers example.com and *.example.com won’t work. You’ll need to buy the Advanced Certificate Manager if you really want it to work.

1 Like

Thank you for your quick reply and for your advice! I’ll remove the www record.

It still remains a mystery why the other record isn’t working…

Thanks,
Lizzie

Did you follow all the steps from this guide, including the Request the Domain’s change in your School Settings section?

I would assume you have not done that yet, as the Error points to prohibited IP error means that Cloudflare does not know your domain (on the receiving side).

If you have done that, check for possible typos.

1 Like

Thans @Laudian ! We had tried to that step, but we got an error when trying to add the new subdomain in our school’s settings. We got in touch with Learnworld’s support and the issue has been resolved now - turns out that it was a problem on Learnworld’s side. They made some changes (not sure what?) and now the domain is up and running.
Thank you for your help :slight_smile:

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.