DNS is propagated but getting DNS_PROBE_FINISHED_NXDOMAIN

I am trying to set up a newly purchased domain, but can’t get it to resolve.

Nameservers set to Cloudflare and confirmed by whois lookup.

A record set (although not to an P address where the www is hosted - does that matter as I have a page rule to forward to www? If it does, which IP address should I use?)
2 CNAMES set and all propagated, yet none will resolve in the browser. Both services that host the CNAMES can see them, but they won’t resolve. Both give

  • DNS_PROBE_FINISHED_NXDOMAIN

Any pointers on how to troubleshoot? I haven’t seen this before.

Did you check DNSSEC?

What’s the domain and what’s the hostname in question?

Not familiar with DNSSEC, but just run a check and found

No DS record
No DSKEY record
No RRSIGs

Everything else is green.

Domain is reviewpusher.co.uk

hostname is app.reviewpusher.co.uk

The record resolves just fine

DNS Checker - DNS Check Propagation Tool

That must be a local issue on your end. Check your local resolver and that it does not use any cached records.

You currently do have a redirection loop and that’s most likely because you have an insecure encryption mode on Cloudflare.

Make sure that’s set to Full Strict.

Thanks for your help. I am still getting issues, but see that it is local to me. I have cleared my browser cache, flushed my dns, rebooted my router and still have the issue, however I have managed to get it working on a 4G connection, so it must be an ISP cache as far as I can tell, which will hopefully figure itself out… If I change the TTL can I force this? Currently set to Auto.

Unfortunately that won’t fix it either. The issue appears to be that your local resolver does provide the correct value yet.

Can you post the output of these commands?

nslookup app.reviewpusher.co.uk
nslookup app.reviewpusher.co.uk 1.1.1.1
ping app.reviewpusher.co.uk

Server: 192.168.5.1

Address: 192.168.5.1#53

Non-authoritative answer:

*** Can’t find app.reviewpusher.co.uk: No answer

Server: 1.1.1.1

Address: 1.1.1.1#53

Non-authoritative answer:

Name: app.reviewpusher.co.uk

Address: 172.67.214.206

Name: app.reviewpusher.co.uk

Address: 104.21.83.52

ping: cannot resolve app.reviewpusher.co.uk: Unknown host

Yeah, that’s an issue with your local resolver.

Should have actually fixed it. Maybe try switching DNS resolver.

For example dns.yandex.com or cloudflare-dns.com.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.