DNS is not resolving

DNS is not resolving the domain my.twilightknights.org to the IP address of my router public IP

Greetings,

Thank you for asking.

  • Might be your ISP is filtering specific ports? :thinking:
  • Check open ports.
  • Check port forwarding, if so.
  • Check app config file / server config file for listening port.
  • Allow Cloudflare IPs to connect.
  • Have a valid SSL certificate for your sub-domain.
  • If the hostname is proxied and :orange: , you would see Cloudflare IP on a lookup.
  • Otherwise, Iā€™d try to setup and configure to use cloudflared tunnel (Argo) + Zero Trust.
  • Else, purchase a web hosting / VPS from some web hosting provider and host files and my app there.
1 Like

I was following this step to resolve with my cloudron app not working anymore. It stopped working so i deleted all the DNS records and rebuilt the Ubuntuu server and reinstalled Cloudron.

4) Turn off port forwarding and go to my.subdomain.domain.com
Expected result, your router login.

This verifies the path between:
[You]-------> [DNS Name Resolution] ------> [IP Address] -----> [Path back home to your server]
If that is good, we go deeper.

I am not sure my router (att residential gateway) allows access.

I have port forwarding on for ports 80 and 443.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.