DNS is not propagated after more than 10h

Hello everyone,

I have 2 websites with basically the same configurations: https://switchswap.io and https://switchswap.finance. I used IPFS to host the frontend, but only https://switchswap.finance got the new content, and https://switchswap.io doesn’t display anything (before updating it worked well).

One week ago, I had the same issue, I tried to change the TXT to another value (to point to another URL) and then change back and it worked, but this way doesn’t resolve the problem now.

I tried to purge cache, put the website in development mode, shorten the TTL,… but it doesn’t work. Does someone know how to resolve it?

Thanks for your help.

I found the cause but don’t know how to resolve. For the IPs in my region (I tried with 3 IP), users can’t access to the website. But using VPN, I can access. I reduced the TTL of my TXT to 1 minute and Browser Cache TTL to 2 minutes but the problem is not resolved. Other VPNs can access the new content quickly after modifying DNS but not my region.

Changing TTL only works after that DNS has propagated.

Which record isn’t propagating? Looking at DNSChecker.org, both domain have “A” records, which are most likely Cloudflare’s flattened record for the root CNAME. And that TXT record shows up as well.

Hi @sdayman, thanks for your reply, maybe I misunderstood the cause when I created this topic.

I tried to access https://switchswap.io with several IP addresses:

  • 4 IP from Paris got an empty page
  • 1 IP from Bordeaux can access the website

It also works well with VPN or Tor. I checked the IP Access Rules but there is no restriction. Do you think that the server that serves my IP is putting a restriction on my IP or having some issue?

With VPN

Without VPN

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.