DNS for the domain is invalid or isnt setup correctly

Hi , we have been using cloudflare for along time. In the past 2 weeks 2 of our domains started getting DNS not found and domain not found errors. They show registered and active on 2 cloudflare nameservers. Its been several days and we still cannot figure out the issue. We cant even get email even though we have MX records setup (and have for many years).

The websites and other records seem to work, and its not for everyone, some mail gets delivered some does not, but whenever it bounces back its either the DNS didnt respond or the dns for the domain is invalid or isnt setup.

Without knowing a domain name or two, we have no way to diagnose this.

Sorry croem.net , croeminc.com , sigmaprocess.net

All under the same account all getting the same error. While I can send from my o365 tenant, from another o365 tenant they get this error. IP= clearly seems wrong but where is that coming from

Reason: [{LED=550 5.4.311 DNS record is invalid or misconfigured [Message=ErrorInvalidData] [LastAttemptedServerName=croeminc.com] [MW2NAM04FT016.eop-NAM04.prod.protection.outlook.com]};{MSG=ErrorInvalidData};{FQDN=croeminc.com};{IP=};{LRT=1/11/2022 2:36:57 AM}]. OutboundProxyTargetHostName: croeminc.com

All your DNS looks good. Domains are valid, and each has MX records that point to mailanyone servers that resolve.

I’m not sure how o365 is involved with your domain, as mailanyone does not look like a Microsoft product.

I’m not sure if that’s literal, because that’s not what your MX records point to.

I suggest you first start with your mail host and ask if they see why there’s a problem with Outlook. As far as Cloudflare DNS is involved, any email-related record needs to be set to :grey: DNS Only, but I don’t think this applies as you’re using third party email, separate from your website.

Its not, thats a trace from someone sending mail from their o365 to my client. The email never even hits their spam filters because DNS fails … its very odd because its not every time but like 50-60%

Its almost as if one of the cloudflare NS servers is giving out bad data.

DNS lookup for what? croeminc.com’s MX record looks quite well-propagated.

Exactly, but I have dozens of senders , sending to this domain that get DNS lookup failure. Not NDR’s or bouncebacks, actual DNS ‘failure’ to lookup the zone. Yet everywhere I look, everything ‘seems’ normal.

I just don’t know how you can troubleshoot their DNS from this end. I’m not even sure what it’s looking up. The error message you posted only mentions the apex domain.

If this is only happening at o365, does it think your mail is hosted there as well?

So this is still an issue today, we just keep getting DNS errors of or

Your message couldn’t be delivered. The Domain Name System (DNS) record for the recipient’s domain is invalid or isn’t set up correctly.

The thing is this is happening on several domains, where email is held at different locations. I even did a dig dns for each of the NS servers (adam/wanda) just to see if maybe one was misreporting.

Have you tried this yet:

Yes thats not it, this is from O365, hotmail , on-prem exchange servers at organizations like american express. On our spam filter we dont even see the connection attempts, which is in line with the ‘DNS not configured error’ as its not even finding the MX records.

We are on the business account for these domains, which I forgot about so I have an open ticket with CF now …

1 Like

Might be worth checking with

which scans for some common issues. It can be very picky about standards but always worth checking.

One issue I’ve seen is misleading errors. It could be timeouts doing a DNS lookup on the MX host names not your domain. Since it only happens from some sites, I’d be suspicious that it’s a connectivity/timing issue and could well be related to DNS lookups on the Mail Anyone servers rather than your domain.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.