DNS for beta.sodapop.cz are not correctly propagated

For our domain beta.sodapop.cz we have set our A record to point to

The backend can be confirmed with:

$ curl -H 'Host: beta.sodapop.cz' --insecure

However when we try to open the beta.sodapop.cz from locations in CZ, this will always end up with:

$ curl beta.sodapop.cz
curl: (6) Could not resolve host: beta.sodapop.cz

I tried that from different computers and different locations in CZ, with always the same result. I can confirm it works from Belgium google cloud servers.

Other DNS within our account propagates correctly, but this one.

dig shows correctly:

$ dig beta.sodapop.cz +trace

; <<>> DiG 9.10.6 <<>> beta.sodapop.cz +trace
;; global options: +cmd
.			6681	IN	NS	e.root-servers.net.
.			6681	IN	NS	i.root-servers.net.
.			6681	IN	NS	c.root-servers.net.
.			6681	IN	NS	l.root-servers.net.
.			6681	IN	NS	f.root-servers.net.
.			6681	IN	NS	a.root-servers.net.
.			6681	IN	NS	k.root-servers.net.
.			6681	IN	NS	m.root-servers.net.
.			6681	IN	NS	d.root-servers.net.
.			6681	IN	NS	b.root-servers.net.
.			6681	IN	NS	j.root-servers.net.
.			6681	IN	NS	g.root-servers.net.
.			6681	IN	NS	h.root-servers.net.
.			6681	IN	RRSIG	NS 8 0 518400 20220209050000 20220127040000 9799 . Vk64l3D95LYXcCVladpSjlCGYXu8NxGqevZbHXfnDtB1VEiir6lGa9ND mI93TyFqCF+AcVUMFTM44qlszV7qEpcPbqf6kIiv+tjqoRhUBiBXg1W4 I4+HBDpiWKTkdR7f4g7brfCcfEvIBR7B1HilrHKUZtTVoLdKh0j/4z2F r4JYhOyiPZV6mFI3vndY3hu0VsOqxyIPS5/YbAwAVWph3NAKgeQwFM3C 7ufsEMZYPpQOHOcAPGCes5wK8UJVIKQ3ANbMOG3yDcxn9rcLJNSN9Zlc mXkfmsOCY4nVNW18Xai6Bm3QMNHuQ2k41Oe13WALre2HX+PaqoTclE9O yYWWPg==
;; Received 525 bytes from in 16 ms

cz.			172800	IN	NS	a.ns.nic.cz.
cz.			172800	IN	NS	b.ns.nic.cz.
cz.			172800	IN	NS	c.ns.nic.cz.
cz.			172800	IN	NS	d.ns.nic.cz.
cz.			86400	IN	DS	20237 13 2 CFF0F3ECDBC529C1F0031BA1840BFB835853B9209ED1E508FFF48451 D7B778E2
cz.			86400	IN	RRSIG	DS 8 1 86400 20220210050000 20220128040000 9799 . IOOmv9U5qhIQUINTOnW7Ohl/DLm/cIgsSkUsGs6LMvSUSqjqJq0u/HSe DLgX2JgWNiBl9AxkhQHzPuidIfzNm4Qos1Vbg24y6hYcB0JOPeuQfTNh 4idUShWQv4BjCrL6spEjpTcllUYzSVj43Nsr0+SCZgqIsw0CqQp4cdBe Wze9uIyFev1vrlkuXwfRxU2+Y/hx8xZXZcyWwHWLsER1TvaVLSyODYxV JEbshFDptAIvvsKbZjo7d8B5vQvPVBZBKL1yrKg+ydEdAlRhokTLyP4j XWb3VtD8+2hKtkTbEGCKfBniMuiksRpy3NGxx+evnDhOAHhrZs9pCAFp Y66dpg==
;; Received 626 bytes from in 9 ms

sodapop.cz.		3600	IN	NS	nash.ns.cloudflare.com.
sodapop.cz.		3600	IN	NS	serena.ns.cloudflare.com.
sodapop.cz.		3600	IN	DS	2371 13 2 02BF0A3CDB28BF41CB93C74414801706878D6D79B99B9E477A6A9860 A89B351A
sodapop.cz.		3600	IN	RRSIG	DS 13 2 3600 20220206074954 20220123061954 63604 cz. JufJcKSsQt9XkIz/ojnoLTCxTg+V5dlFclbWpIPBV5bEsm/UuH3CGbuh IWn4pJyy17FvsNpaFwwgQEEQGa0pwQ==
;; Received 247 bytes from in 15 ms

beta.sodapop.cz.	300	IN	A
;; Received 60 bytes from in 11 ms

Why that?

Why that?

I don’t think that is relevant here.

I can’t get anything to resolve. Are you sure you have the appropriate DNS records here? And that the name servers at the bottom of the DNS settings page are Nash and Serena?

It is, because if you have a broken server setup, things won’t work.


also see the dig above which resolves the url correctly.

backend server is not relevant for DNS resolving. I put it there just for completeness.

also this resolves the url correctly DNS Checker - DNS Check Propagation Tool

Ah, it looks like your DNSSEC is broken. Turn that off at your registrar, or set it up properly based on the DNSSEC settings here.

EDIT: Correction…was broken. It looks like you just changed something. The screenshot below is from before you fixed it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.