DNS Error for Rookie - Need Help


#1

My web host says the following two DNS records are needed …

A … domain … IP address
CNAME … domain … eb4us.com

My domain registrar is EasyDNS and I was able to put both these records in their DNS settings, and the website worked.

But when I try to add the second record to CloudFlare, it gives me an error of “An A, AAAA or CNAME record already exists with that host. (Code: 81053)”

I tried deleting the current default record of “CNAME … www … is an alias of mydomain.com” and replaced it with the eb4us.com record above? But the site won’t resolve.

Any ideas? MANY thanks! - Joe


#2

I’m a visual guy… here’s a basic CNAME setup:

Is this what your DNS settings look like? It sounds like it, but I just wanted to confirm…

edit: note in this screenshot the A record has the IP redacted but obviously yours will have your origin IP.


#3

Yes … it did look like that when I first set up the CloudFlare account. But the domain wouldn’t resolve. Here’s what it looked like in EasyDNS

CloudFlare doesn’t want to support both domain level C-NAME records … or I don’t how how to get it do allow them.


#4

You don’t appear to be using Cloudflare nameservers. Have you changed them at your registrar?


#5

I am using CloudFlare name servers and CloudFlare says the domain is Active.

Above I showed you the EasyDNS settings because these worked before I setup the domain with CloudFlare.

Now I’m trying to duplicate this setup in CloudFlare but get the error.

UPDATE: Apparently, there was a delay along the way somewhere. Now the site is loading properly the way I have CloudFlare setup. Sorry for wasting your time. But thanks for your help.


#6

Not wasting my time :smiley:

However, dig eb4us.com NS +short shows that you’re using your own nameservers, and not the Cloudflare ones. The Claire Chrome extension also shows that your traffic is not being routed through Cloudflare. Propagation may take 24-48 hours if you have indeed verified that you’ve set your nameservers at your registrar to the provided Cloudflare nameservers.


#7

OK. I guess I don’t understand … well … I know I don’t fully.

Understand that eb4us.com is a “shared site or server” (if I’m using those terms correctly.) So maybe that has something to do with what you’re seeing. It’s a website development platform that I’m testing – specifically now to see if it will play nice with CloudFlare.

Earlier today I set up the EasyDNS DNS records to get the site working properly. At that time, the name servers stayed with EasyDNS and the DNS records were set according to the earlier picture – as the web host required. All worked well. My site loaded.

Then I added the domain to my CloudFlare account to see if it would work there. CloudFlare wouldn’t take both CNAME records related to the primary domain. Adhering to the CloudFlare setup sequence, I changed the nameservers at EasyDNS to point to CloudFlare as CloudFlare requires. CloudFlare confirmed – and still reflects – Active status.

Then, per my web host’s requirements, I tried to add the second CNAME record for eb4us.com, but got the CloudFlare error. I then changed the www record to an alias of eb4us.com instead of an alias of my domain, just to see if that might work. It didn’t, so I started the community thread we’re on now.

But now it at least appears that everything has worked itself out. The site is loading again.

But it sounds like you’re saying the traffic isn’t even going through CloudFlare yet. So, what does Status = Active mean in CloudFlare?

Many thanks for your patience,

Joe


#8

You are not. Check here: https://www.whatsmydns.net/#NS/eb4us.com
You are using ns1.eb4us.com and ns2.eb4us.com

It should be something like this: https://www.whatsmydns.net/#NS/webveteran.com

Contact your registrar and ask them to help you.


#9

eb4us.com is NOT my domain. That’s my webhost, and they require my domain be routed to them with both an IP address for the A record and the www CNAME to eb4us.com.

My domain is fts-business.com. If you put that in whatsmydns.net, it’s using CloudFlare name servers.


#10

Hi. Thanks for clarifying. There was some confusion over your actual domain I think.

Your domain appears to be using Cloudflare nameservers and traffic is routed through Cloudflare correctly. Sorry for the confusion!


#11

No apology necessary. Thank YOU for the effort to help me. I truly appreciate it.