DNS-Error 1000 on connecting `medium.com` custom domain


I trying to re-configure my medium custom domain.

The custom domain is https://blog. etherisc. com.

Medium provides a list of IP-Addresses which are configured in our DNS-Setup at cloudflare. In the past, this was a list of about 12 IP-Addresses and this has been working nicely for years.

However, recently, medium has changed the IP-addresses of the custom domain service.
The new IP-Addresses are and

We have configured these addresses in our Cloudflare DNS dashboard. There is no proxy configured:

However, when I access the URL https://blog. etherisc. com, I receive this error:

Error 1000

Ray ID: 80905e4fac3b6d8b • 2023-09-19 08:13:16 UTC

DNS points to prohibited IP

What happened?

You’ve requested a page on a website (blog. etherisc. com) that is on the Cloudflare https://www. cloudflare. com/5xx-error-landing/ network. Unfortunately, it is resolving to an IP address that is creating a conflict within Cloudflare’s system.

What can I do?

If you are the owner of this website:
you should login to Cloudflare and change the DNS A records for blog. etherisc. com to resolve to a different IP address.

I tried to contact the medium.com support but received this answer:

Hi Christoph,

Your IP is being returned as “prohibited” by Cloudflare and there’s nothing we can do to fix this.

*You can try sending an email that describes the issue to Cloudflare at [email protected].

If they’re able to resolve the issue for you, try unlinking and re-linking your domain on Medium to get it to work.

If they’re unable to resolve it for you, unlink your domain in the Medium custom domain settings and use the http://medium.com/ URL instead of your custom domain going forward.

User Services

Please advise. Most likely many medium.com users have custom domains hosted on cloudflare so this issue should be widespread.


This error means that medium is now using Cloudflare for their services.

If you look at IP Ranges, you will see that the IPs you listed are part of the following range:

As their site is now on Cloudflare, medium will need to follow Cloudflare’s process for adding custom domains, which you can find here: Cloudflare for SaaS · Cloudflare for Platforms docs.

Until they have done so, there is nothing you can do. Have you tried to just continue using the old IPs? If you are lucky, direct access to those was not blocked.

Edit: What you could try is removing your custom domain and going through the setup process again. Maybe they are using Cloudflare for SaaS but the changes were not correctly applied to your account.

1 Like

Hi Laudian,

thx for the info. Actually, disconnecting and re-connecting did the job.
Obviously Medium is using the Cloudflare SaaS plugin and it works.
Don’t know where the hiccup came from.



This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.