DNS ERROR (0 records found)

#CommunityTip
I am new to Cloudflare.
Just trying to add my site to Cloudflare and get an error saying “0 DNS records found”
What should I do???

This is a known issue. Wait a bit and the records should be imported nonetheless. That is, of course, assuming your current nameservers have the proper records in place and can be scanned.

Actually, i was already using cloudflare for few months. Few days back, just for checking what happened when i remove DNS, i actually remove DNS records.
And then it didn’t came back.
So i deleted my site from cloudflare and again trying to add, then this will happen.
0 DNS records found.
Now what should i do??

Did you change your nameservers when you removed the site? Otherwise Cloudflare obviously cant scan for any records and you will have to set them up manually.

Yes, currently my nameservers are changed to default godaddy nameservers. And all DNS records are visible under godaddy DNS.
Did i need to add manually all the DNS from godaddy to cloudflare??

And you newly readded the domain? In that case my original statement should apply.

Yes i newly readded the domain and stopped at the 3rd step where no DNS records are found.
So according to your first statement, i have to add DNS records manually from godaddy to cloudflare.
I am new and afraid if again i did something wrong that’s why i am asking that,

I have to add all the 6 DNS records exactly same to cloudflare, right?
below are the record types that are visible under godaddy dns records with name, value and TTL…

  1. A
  2. CNAME
  3. CNAME
  4. NS
  5. NS
  6. SOA

DID i need to change something like type, name, value or TTl ???

Hello???

You shouldnt stop there but simply proceed. The records should show up eventually.

I didnt say that. I said you should wait. Only if your domain cant be scanned you will need to set it up manually.

Ok i understand.
I have to proceed and change the name servers without adding DNS. And the DNS will shown up eventually.
I just need to change the Nameserver and nothing all, right??

Whats the domain and when did you add it?

findmytricks.com
Added and deleted many times since yesterday. I mean with 0 DNS records found, i deleted and tried again. I didn’t change the nameserver yet because i am affraid of any error.

Alright. Yes, your domain still points to your registrar.

At this point I’d remove the domain from Cloudflare and start from scratch. Re-add it (and dont stop at any step) and wait until the records have been imported, then switch the nameservers.

Should Cloudflare still not have imported them after a couple of hours, you can either simply add them manually or contact Cloudflare’s support.

Ok thank you.
I am going to add it again.