DNS CNAMEHostTest Failed Unable to transfer zones

CNAMEHostTest Failed
dns test status = FAILED!

I don’t seem to be able to transfer some domains to cloudflare dns due to this error.
The zones I created are identical on cloudflare and the old provider.
Also, I tried to upload the pri.domainname.tld file to cloudflare, and the exact same operations worked for other domains.

shot868|373x288

Your screenshot did not upload. What is the domain in question?

1 Like

mdengineering.it

Cant resend shot now but it shows all tests are correct, but this CNAMEHostTest.

-------- Messaggio originale --------
On 18 mag 2019, 20:22, sandro via Cloudflare Community < [email protected]> ha scritto:

Hi, all the records seem correct, unfortunately without the screenshot it seems impossible to understand. Let’s wait until your are able to do so.

I for sure can tell you that the nameservers aren’t yet transferred, but that is probably caused by the error you are mentioning.

What exactly do you mean by transfer? An .it domain cant be transferred yet.

And as far as adding it to Cloudflare is concerned, Cloudflare does announce nameservers for it, however you havent changed your domain’s nameservers yet, so the domain will neither validate on Cloudflare nor be served by/through Cloudflare.

@sandro I don’t mean to transfer the domain to cloudflare registrar, this isn’t allowed yet for .it and I know.

But as far as I understood, they still can host my dns zone in place of my registrar. I already achieved this with some .com, now I’m in doubt the issue could be the tld, since this isn’t the only domain failing to transfer.

My tests follows, I appreciate your contribution.
https://imgur.com/a/TfWFWQy

img 1) The screenshot that didn’t uploaded.

More tests you could try to diagnose: https://dns-check.nic.it

img 2) configure tests as follows:

img 3 and 4) Results I’m getting indicates 94.23.72.137 (the mx record’s resolved ip) can’t be resolved:

img 5) BTW it’s not true!! :frowning:

Also, .com has same mx and spf records mentioning mail1[dot]mlnz[dot]net and it smoothly migrated to cloudflare in less than 6 hours.

Sorry if it’s not easily readable, I have limits for links and images.

Where did you take this 94.23.72.137 from? That shouldnt be used anywhere.

Cloudflare issued the two nameservers bella and kurt to you, right? What happens if you set these two nameservers with your registrar?

The img1 shows what happens when my registrar sets bella and kurt as nameservers for the mdengineering .it domain. I opened a ticket with them, and they replied with this error log from the zone transfer attempt at their end.

The tests at dns-check nic.it service can let you replicate the same issue. Try it please.

I didn’t take it anywhere, it is, as stated in the post before, the ip address of mail1.mlnz.net, this server is the mx record for the domain mdengineering .it

My apologies, the UI at check.nic.it seems to be glitchy and used a different domain.

Let me run another check.

1 Like

All right, got it. Remove the MX record on Cloudflare’s side. Once that is done it should validate.

Afterwards you can add an MX record again, however it should be a hostname, not an IP address.

I’ll try that at night time, since mdengineering won’t be receiving mails meanwhile…

BTW, .com already passed has the exact same DNS zone as those .it failing.
Might be different checks for this tld??

It does depend on the registry. .it in particular is very strict in this regard.

You can change it right now as well. The MX record at Cloudflare is not active yet anyhow, as the nameservers are not set yet.

Even better, dont remove the MX record but change it from the IP address to mail1.mlnz.net. In this case it should validate as well.

it did. Thank you so much @sandro !

I should get back to https://www.isc.org/community/rfcs/dns/ :grin:

1 Like