DNS Changes Not Working-- Conflict with Old Host?

I used to point my domain to a shared host that uses Cloudflare (via A records). After deciding to move hosts, I set up a new account on Cloudflare and successfully set up the domain there using the nameservers.

The domain is danielfoster.net.

Even though my records are proxied through Cloudflare, the records are not being respected. When I enter https://www.danielfoster.net, it always redirects to my old redirect. This occurs even after:

  1. Waiting 30 hours
  2. Clearing my DNS cache and using an incognito browser
  3. Clearing Cloudflare cache
  4. Ensuring the orange cloud is lit up

Entering the domain without www seems to work.

Even more frustrating, online DNS checkers show that the correct Cloudflare nameservers but still show the A records for my old host.

These are my DNS records:

These are my redirect rules:

Any idea what is going on here? I am beyond frustrated. The only thing I can think of is that since my old host used Cloudflare, the set up some sort of rule that is conflicting with mine.

Was your domain with Format previously? It looks like they use Cloudflare for SaaS which can cause this issue if they do not remove your domain properly when you move away.

This explains it and gives you steps to get it resolved:

1 Like

I have similar issue . When i replaced bluehost name server name with Cloudflare’s my domain name became out of reach . I was told to wait up to 48 for it to propagate. But unfortunately it’s 60 hours now and it remains the same .

Thank you for this-- it is extremely helpful! I have contacted Format and also tried to take ownership of the http records, though this is still pending.

Is there any way to know for sure that Format still has ownership of the domain on Cloudflare? I was not able to find the records in a DNS lookup. I also want to make sure that my domain provider, Namecheap, is not the culprit.

The fact that the site does not point to them in DNS but shows a Format branded page is probably enough to indicate this.

You could use Liberate the Hostname (outlined in the tutorial) for a quick fix.

The liberate tool worked! Normally with DNS issues it’s hard to believe you are not at fault (cache, waiting for propogation, misconfiguration, etc.) and I spent hours troubleshooting this issue until you responded. Format.com’s customer support also seems to be unaware of this and wasn’t able to provide a fix.

I am extremely grateful for your help. Thank you again!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.