DNS blocks icloud.com

I’ve added 1.1.1.1, 1.0.0.1, 2606:4700:4700::1111, and 2606:4700:4700::1001 to my DNS settings in macOS system preferences per the instructions.

Everything works fine except for icloud.com, it will not load at all. As soon as I remove Cloudflare’s DNS servers, I can load the page. Same behavior in Chrome and Safari.

The funny thing is that the page loads on my phone when using the 1.1.1.1 app in both 1.1.1.1 mode and 1.1.1.1 with WARP+. But when I put the custom DNS addresses in my router settings, it again prevents loading icloud.com from my phone on wifi.

That’s not quite what happens to me. When I use a VPN (personal, or Warp+), iCloud/App Store/etc. doesn’t work right. Otherwise, I’m almost always using 1.1.1.1 for everything and not having Apple connectivity problems.

Does your connection actually support IPv6? You might be running into issues there.

It does. My private VPN is IPv4 only, but my home connection is IPv6, so WARP should be using that.

I have a Homekit camera that won’t stream through either of my VPNs using the Home app. Turn off VPN and it works fine.

That’s with Warp, though, which makes sense–a lot of providers block VPNs. I would expect iCloud to work with DNS-only, though, since I’ve never had any issue with it myself. The fact that it works for @tenstairs when using the app on the phone but not when configured in the router makes me think it’s an IPv6 issue.

It could be a country issue. For me, no matter where I happen to be in my part of the US, WARP DNS will always peg me to be in the US. But with…ECDS, it may throw off geolocation and cause iCloud services to be restricted.DS

As far as I can tell, iCloud doesn’t require ECS to function, and you’re probably going to be geo-restricted based on your actual IP address rather than ECS. If ECS were in use, you might end up geo-restricted based on both, but switching to 1.1.1.1 shouldn’t result in you being geo-restricted—if anything, it would have the opposite effect.

1 Like

I haven’t done anything differently, but I’m now able to load the icloud site using Cloudflare’s DNS. Maybe Apple fixed something on their end?