DNS Autodiscover / MX / SPF Records


#1

Hi all,

I believe I have a few issues with my DNS settings. I recently updated my MX records to point to a new Exchange Service with Giacom (Cloud.Market). The MX records have now propogated (48+ hrs!) but the likes of the autodiscover, SPF & OWA are not working.

I have added the SPF record as per the email hosts instructions, but reading around the forums users are saying add it as a TXT record as opposed to SPF?

Would it be safe for me to post my DNS settings in order for you to help me?

Provider settings; "

MX Records

inboundcluster1.giacomcp.com
pref/priority 10
inboundcluster2.giacomcp.com
pref/priority 10
inboundcluster3.giacomcp.com
pref/priority 20
inboundcluster4.giacomcp.com
pref/priority 20

Autodiscover Record
autodiscover.thomasperformance.co.uk

CNAME
autodiscover.giacomcp.com
TTL (lowest possible)
OWA Whitelabel
owa.thomasperformance.co.uk

CNAME
owa.giacomcp.com

SPF Record
include:giacomcp.com
which should resolve to: v=spf1 include:spf.giacomcp.com -all

"

Kind regards,
Thomas


DNS CNAME problem
#2

OK, so now the issue is just the autodiscover.

It needs to be autodiscover.thomasperformance.co.uk resolving at autodiscover.giacomcp.com however it strips out ‘.thomasperformance.co.uk’ and I think this may be a requirement?

I have it as a grey cloud.

I have also since deleted the SPF record and re-added as a TXT record. Some of the settings above were incorrect too, owa.thomasperformance.co.uk is now webmail.thomasperformance.co.uk.

Cheers,
Thomas


#3

It appears to be resolving to what you’ve input:

dig autodiscover.thomasperformance.co.uk +short
autodiscover.giacomcp.com.
185.145.48.71
46.175.48.71

You can test the output/values using the Outlook Autodiscover test here: https://testconnectivity.microsoft.com/


#4

Thank you for your reply, it is greatly appreciated. I’m glad you have confirmed that. I am testing autodiscover, but can see issues. Could Cloudflare be blocking ports, even if I pause?

"Attempting to test potential Autodiscover URL https://thomasperformance.co.uk:443/Autodiscover/Autodiscover.xml

Testing TCP port 443 on host autodiscover.thomasperformance.co.uk to ensure it’s listening and open. The specified port is either blocked, not listening, or not producing the expected response."

This could be part of the issue? How do I go about getting around this.

Regards,
Thomas


#5

i need ton propagate cdn1.liffyworld.com cname so please help me to do this


#6

I see you have some sort of DNS entry, but it looks to point to something already using Cloudflare.

What have you tried so far? If it really pointing to a domain already on Cloudflare, try setting that entry to :grey:


#7

what i do can u clearly say me to solve this problem and also to make secure https and also a green padlock in my site


#8

also return your connection to liffyworld.com is encrypted with 128-bit encryption. however this page includes other resources which are not secure. these resources can be viewed by other while in other in transit, and can be modified by an attacker to change the look of the page.

the connection uses TLS 1.0.

THE connection is encrypted using AES_128_CBC, With SHA1 for message authentication and ECDHE_RSA as the key exchange mechanism.

the connection is not compressed.


#9

Your site has a mixed content warning.


#10

so i m using wordpress can u tell me how to solve it


#11

You have several font files loading over HTTP. Some are Google Fonts, and a couple come from your Stackpath CDN.

  1. I suggest you go to your Wordpress dashboard under Settings (General), and set your site’s URL to https. If you can’t set it there, you will have to edit your wp-config.php so it has:

define(‘WP_SITEURL’, ‘https://liffyworld.com’);
define(‘WP_HOME’, ‘https://liffyworld.com’);

  1. Find out why your Stackpath URL is http. You probably have a CDN plugin that sets this.

I’m attaching a screenshot of the mixed content warning.


#12

please help me to make my site fully secured it also opening in http i only want to open in https secured website can u help me to this or u do for me


#13

This is beyond the scope of Cloudflare. If you need Wordpress help, I suggest you look for a Wordpress consultant who can help you maintain your site. You can find Wordpress consultants at https://www.fiverr.com/


Convert complete site http into https
#14

yup now it solve can u tell me how can i speed up my site with correct configuration with stackpath cdn + plus wordpress + w3t so it will speed up


#15

Turn Cloudflare on for your domain. It will do a better job of caching and HTTP/2 will speed up content delivery.


#16

yup i turned on but it take time to load can u tell me which option is good to open for my site means turn on features which is available in clouflare