DNS auto populating and Ezoic Issue

Hey Guys
So I am facing a very bizarre issue with Cloudflare’s DNS. To Explain let me tell you what i am using as a backend.

I have a Linode server running WordPress for my personal/ Test Blog. And I have purchased my domain through Hostinger. and at some point tried ezoic.

So my issue is since I am using A VPS I have to delete all my previous Records(Which was more time consuming than I thought cause there were 7-15 records) and add a new A and AAAA Record and i have done this many times as expected everything worked fine at first. but after 2-3 hours upon visiting my websites it said “Error communicating with origin” and all my newly added records were replaced with those old records that contain some ezoic proxy. And This Error was clearly ezoic fault as per this Topic. So I re deleted all my records and placed new records. But the same thing happened again. which clearly is Cloudflare’s fault

Since i am a novice please guide me.

Hold on there. Cloudflare doesn’t change records all by itself. It’s either through a login on your account, or through an API call because you gave someone your API Key.

Check the Audit log at the top of dash.cloudflare.com and you should see how this happened.

But the two-step fix is:

  1. Change your login password
  2. Reset your API keys (and tokens if you have any)

https://support.cloudflare.com/hc/en-us/articles/200167836-Managing-API-Tokens-and-Keys#12345681

1 Like

yep Thanks for Pointng me at right direction. After checking the logs it seems like te records are added through API from this IP “44.193.219.54” I have to do more indepth digging to find out whose service is this but as for now i have changed my global API and my pass

Thanks

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.