DNS and HTTP proxy not working, CF resolves original IP address

#1

Hi,
I’ve switched on “DNS and HTTP proxy (CDN)” on DNS settings for “A” and “CNAME” records, but CF resolves original server IP address.

dig sppcrm.ru @8.8.8.8

; <<>> DiG 9.10.3-P4-Debian <<>> sppcrm.ru @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64432
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;sppcrm.ru.      IN  A

;; ANSWER SECTION:
sppcrm.ru.    299  IN  A  176.122.24.27

#2

You need to set domain DNS servers to what provided by Cloudflare to you (from domain registrar panel).

1 Like
#3

It’s already delegated to CF

$ whois sppcrm.ru
% By submitting a query to RIPN's Whois Service
% you agree to abide by the following terms of use:
% http://www.ripn.net/about/servpol.html#3.2 (in Russian) 
% http://www.ripn.net/about/en/servpol.html#3.2 (in English).

domain:        SPPCRM.RU
nserver:       albert.ns.cloudflare.com.
nserver:       zelda.ns.cloudflare.com.
state:         REGISTERED, DELEGATED, VERIFIED
org:           Obschestvo s ogranichennoy otvetstvennostiyu "SPP"
registrar:     REGRU-RU
admin-contact: http://www.reg.ru/whois/admin_contact
created:       2016-09-07T14:36:59Z
paid-till:     2019-09-07T14:36:59Z
free-date:     2019-10-08
source:        TCI

Last updated on 2019-05-14T17:21:32Z

$ dig sppcrm.ru @zelda.ns.cloudflare.com

; <<>> DiG 9.10.3-P4-Debian <<>> sppcrm.ru @zelda.ns.cloudflare.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60728
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;sppcrm.ru.      IN  A

;; ANSWER SECTION:
sppcrm.ru.    300  IN  A  176.122.24.27

;; Query time: 46 msec
;; SERVER: 173.245.58.242#53(173.245.58.242)
;; WHEN: Tue May 14 20:22:51 MSK 2019
;; MSG SIZE  rcvd: 54

$ dig sppcrm.ru @albert.ns.cloudflare.com.

; <<>> DiG 9.10.3-P4-Debian <<>> sppcrm.ru @albert.ns.cloudflare.com.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7963
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;sppcrm.ru.      IN  A

;; ANSWER SECTION:
sppcrm.ru.    300  IN  A  176.122.24.27

;; Query time: 48 msec
;; SERVER: 173.245.59.58#53(173.245.59.58)
;; WHEN: Tue May 14 20:23:38 MSK 2019
;; MSG SIZE  rcvd: 54
#4

You have paused Cloudflare (on the overview page you can resume).

2 Likes
#5

Thank you!
Have a nice day @cscharff

1 Like