DNS and HTTP Proxy - Not showing our Certificate


#1

We have a site where we have provided our own certificate from Comodo. When I turn on the CloudFlare proxy, the certificate shows a certificate from CloudFlare and not the one we issued. When I turn off the CloudFlare proxy, it shows our certificate in the URL. Im hoping for the best of both worlds where we have the CloudFlare proxy turned on and it shows our certificate in the URL. Hoping it is something easy. Thanks in advance.


#2

It’s normal behavior, Cloudflare is PROXY betweven your server and customer, connection between Cloudflare and your server is encrypted using your Comodo certificate, but connection between your customers and Cloudflare is encrypted by certificate from Cloudflare.

End-to-end encryption is impossible between customer and your server unless Cloudflare proxy is turned off. Cloudflare has to cache your content and it’s not exactly possible to cache encrypted traffic. They have to decrypt it, cache and encrypt it again to serve your customers.

I think it’s possible to use your own certificate on Enterprise plan but no experience with that.


#3

It’s available also on Business, but limited to one certificate.

Usually a custom certificate is not needed. It’s better to use Cloudflare’s Origin ones and potentially use the dedicated that Cloudflare offers.


#4

This topic was automatically closed after 30 days. New replies are no longer allowed.