DNS Alias not working


I am hoping someone can help me figure out how to get this CNAME alias set up properly.

These are the steps: https://help.shootproof.com/hc/en-us/articles/115009450987-How-do-I-set-up-a-Custom-Domain-

When I follow them I get the error in browser saying that it can’t load because it is redirected more than 20 times.

I have attached an image of the current dns set up. I had it working previously with google dns but not sure what is missing here.



You did not share the domain so it is slightly difficult to test. However, you have a few choices.

  • Enable SSL Mode “Full” either at a zone level or via a page rule for each of the two hostnames.
  • Set the two records to :grey:

You probably have SSL Mode Flexible at the moment, and Shootproof are redirecting the request to HTTPS also. These two things combine to cause the redirect loop.

1 Like

It didn work. Im with the same problem

Can you share the domain?

What did you change? Can you share a screenshot?

The configuration on Shootproof is not very particular, it just redirects everything without even checking if it is a valid string.

% curl http://clients.shootproof.com -H "Host:" -v 2>&1 | grep Location
< Location: https:///

Hi Michael,

Thanks so much for your reply.

Yes I do have it on flexible at the moment. Our website has an SSL certificate already, will this cause any issues? I am not really sure what this setting does to be honest.

I just copied everything over that was in our Google DNS settings so I was definitely surprised it did not work.

For now I have changed our nameservers back to Google DNS. So I am not sure if sharing the domain at this point with it not set up will be helpful, but feel free to let me know otherwise.

Thanks for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.