DNS A Records not updating


#1

I have done this a bunch of times, but this time the A records wont point to the new server. I have tried to wait over an hour. I tried to set it to DNS only and also tried to add and remove the A records, but nothing seems to work. Is there anything else to try?

Domain: kjellhaglund.com


#2

What exactly is not working? Your domain correctly resolves to Cloudflare’s proxies.

Please dont tell me you expect other IP addresses than 104 :wink:


#3

Nah, I wanted it to point to another server. Worked after I deleted the CF account and re-added it.


#4

I’m seeing a similar problem — I have two domains on Cloudflare, I’ve updated CNAME, A, and TXT records over the past hour on the DNS app, and those changes haven’t propagated at all.


#5

That should not be necessary, but anyhow it seems to work now.

Do they point to 104 addresses? Whats the domain?


#6

They did point to 104 addresses — everything was being successfully proxied through Cloudflare. However, when I ran e.g. dig domain.com TXT, the changes were still old values from around an hour ago.

It seems to have been fixed now though — right after I posted the above, everything was resolved. Never seen Cloudflare be so slow to update, which made me a bit worried.


#7

@tyxchen Do you know about how long it took for your records to finally proapgate? I’m experiencing the same thing, I think it’s been close to an hour for me. I was originally trying to update some certificates with certbot, but unable to use Cloudflare for authentication because it can never read the TXT records that it creates. I’ve been testing adding some A records too but am not getting a response when I try to query them with dig.

Also, it seems that this problem has been going on for me at least since Thursday, judging by certbot logs. When It tries to do the verification, I can see the TXT verification records in the web interface, but both certbot and dig fail to find them.


#8

Scratching my head this morning only to come across this thread. I’m having the same issue - tried to create a new subdomain with an A record and I’m not getting any DNS record showing up, whether I ping locally or using MX Toolbox. I’ve done this method 100 times before and never had any issues - so looks like some issues on CloudFlare’s end.
My nameservers are earl and sofia.

Edit: Records have finally updated after ~15 minutes.


#9

There’s a Status alert that there are delays of up to 60 minutes:
https://www.cloudflarestatus.com/incidents/cktscy5xv4w3


#10

Unfortunately can’t put a specific number to it, but I think it took around an hour as well.