DNS A Records Not propagating

A DNS Records on cloudflare domain not propagating

I bought the domain kewlquokka.uk from cloudflare and have updated the A record to point to a IP address hosting a game server. For whatever reason, I cannot get the DNS records to propagate. It has been several days with no change, no matter if I disable the cloudflare proxy and have DNS only whenever I do an NSLookup or try to connect to the server with the domain name I own it either resolves to the cloudflare servers or does not connect.

I have tried pauseing cloudflare, enabling developer mode for the domain but nothing seems to work.

Have I done something wrong or is this a Cloudflare issue?

Thanks for all the help and support.

It resolves fine

but it resolves to the proxies. If you don’t want that you need to unproxy.

I have them unproxied at the moment, that is the issue. And with it proxied it does not redirect to my server anyway.

Can you pause Cloudflare altogether?

If I do that then there are no records.

I have tried setting up DDNS as well to ensure its not just me and even that cannot get my A records to propagate. I have even tried setting my DNS A record to google with no luck. I am really not sure what is happening.

All right, post a screenshot of the entire page of https://dash.cloudflare.com/?to=/:account/kewlquokka.uk/dns/records

And that is a current screenshot?

Yes it is, is something wrong?

Did you configure this domain on any other platform which may also use Cloudflare?

No, I don’t believe so.

I suggest you open a registrar ticket at https://dash.cloudflare.com/?to=/:account/support and ask them for clarification as something with your domain registration must have gone awry. The domain is registered with Cloudflare and uses the correct nameservers, but its DNS settings are not remotely applied. The configured entries do not resolve as they should and you appear to have a wildcard entry, even though you did not configure one.

Based on the information you posted, it appears as you configured everything correctly and you need support to fix that. I am afraid the community can’t help here.

Thankyou so so much for your time with this. At least I know I am not going crazy now.

No, if everything is as you posted, you are definitely not going crazy :slight_smile:

Well as I am not a pro user and only bought my domain through cloudflare they will not help with DNS. I just get sent back here. Any other Ideas?

Did you open a registrar ticket, as mentioned? This won’t be a registrar issue per se, but as your domain is registered with Cloudflare, you can still open it and support can shift it if they want.

Simply state

  • the domain uses the correct nameservers (it is registered with Cloudflare anyhow)
  • your DNS entries are not proxied but yet everything resolves to the proxies
  • there is a wildcard even though you did not configure one

I just get an automated response saying this sounds like DNS, go here (community site) to get support

You opened a registrar ticket?

Yeah, then there was an automated reply saying “This looks like you require support for DNS”, then pointed me back here