DNS A record update, but still resolving to old IP

Hi all,
I have an issue I have never come across before.
I have launched a new site for a client on a different web server. I have updated the root A record to the new IP address.
However, the domain still resolves to the old IP 2 days later, showing the old site.
If I pause Cloudflare, within in 5 mins the domain resolves to the new site, but now I don’t have Cloudflare security and caching.

I Cloudflare paused for 24 hours and unpaused Cloudflare, and when Cloudflare was enabled again, back it goes to the old site.

Any ideas or suggestions

try to use DNS Checker - DNS Check Propagation Tool

Greetings,

Thank you for asking.

May I ask if you used some hosting provider to enable and integrate Cloudflare for your domain name as a SaaS like Kinsta, WPEngine, eZoic, etc.? :thinking:

If yes, could you ask them to check just in case if there is some CNAME record / hostname for your domain name at their side left?
It knows to be an issue when we use some hosting providers which enable SaaS for our domain name/website.
Kindly, ask them to re-check this and remove/delete if so.
Furthermore, I’d suggest you to follow the instructions from the article below as they are related to any SaaS integrator:

Thanks!
I did use this and checked, when Cloudflare is paused it exposes the correct IP address, when Cloudflare is enabled again, I see the Cloudflare IPs so it doesn’t identify to me the problem.
I even tried to do a DNS flush using Google’s public DNS flusher to no avail.

No use of other services to manage the domain with Cloudflare, this Cloudflare account was configured by myself 5 years ago.

Have you flushed your local DNS cache? Might be due to the local ISP.

Have you tried to “Purge Everything” under the Caching → Configuration? :thinking:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

All great questions, I should have clarified all these things. So thank you for asking.

Cloudflare cache has been purged numerous times.
Local cache has been cleared on the router and the machine.
Different browser and device attempted on different networks and different users. (Client and myself)
Moved VPN to another country, same result.
Private window is my go to, as I want to test server side caching, same result.
Same behavior on my mobile phone, not on the wifi network, but on mobile data

If Cloudflare is paused. the correct website appears in all scenarios above.
If I unpause Cloudflare, the old A record IP is resolving and the old website is displayed, in all scenarios above.
Certainly is feeling like Cloudflare cache is not flushing DNS on change.

please keep any other thoughts coming, as I will go through all the processes again to double/triple check things.

Thank you for feedback information.

I might not know exactly :thinking:
Is there any difference at all while accesing your website with www prefix vs. without www?

Kindly, I’d suggest you to write a ticket to Cloudflare support due to your account and/or domain issue and reply back here and share the ticket number with us so we could escalate this issue:

  • Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button. If you get automatic reply, reply and indicate to it you need more help and reference to this topic
  • Or send an an e-mail to support[at]cloudflare[dot]com from your e-mail associated with your Cloudflare account

I did try have A records for WWW and for the root… and then I even swapped, so www is the a record and the root domain is CNAMEd to www… just in hope that it will bust the cache. but yeah didn’t get any luck.

You’ve been most helpful! I’ll reach out to CF directly as you’ve said and will update this thread further

Support ticket: 2380112

1 Like

Thank you for sharing the ticket number. I’ve escalated this.

Kindly and patiently wait for a reply here and on a ticket too.

In the meantime, may I ask if you are using the same hosting provider like “new IP = new server, same hosting provider”, or you changed them? :thinking:

Have you tried contacting your “old” one (or if it’s the same, just different server) just in case if there is something “tied” and left related to your domain name and/or DNS, if so?
I m just guessing as there were some topics for example where users changed from one server to another within the same hosting provider like AWS and similar.

Is the old/new IP address static/failover maybe? :thinking:

Thanks for asking.
New hosting provider, I will get the client to reach out to the provider of their old website to check on that. Great idea!
It’s just funny that pausing and unpausing Cloudflare makes all the difference.

result back from the above ticket, is solved. Issue is most likely related to Cloudflare resolver.
So I am needing to create a community topic under this category instead.

I’ll do this, but also get the client to touchbase with the old host and see if there is anything lingering in their system

Hello,
I created the following support ticket with Cloudflare, however, it has been resolved to reach out to the Cloudflare Resolver community
https://support.cloudflare.com/hc/en-us/requests/2380112

The domain has been on Cloudflare’s network for a number of years; and on Friday last week, I updated the IP address for the A record to resolve to a new server/hosting provider where the new website is.
If Cloudflare is enabled, the old website is resolved, when pausing Cloudflare the new website is resolved.

I have tested across various devices, networks, VPNs etc. and it all just keeps coming back to, once Cloudflare gets paused, the website resolves to the correct server.

Any assistance or advice regarding Cloudflare resolver would be most appreciated.

A post was merged into an existing topic: New site not showing when cf active

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.