DNS A record is not being seen by Azure

I have added the DNS A record and made it DNS only (no proxy) yesterday and yet Azure is still not able to detect it. Azure requires the Host (name) to be the @ sign while the one here is set to my domain name Could this be the issue? The TXT record is being detected fine its just the A record I’m having trouble with. 

I get this message from Azure:

No matching A Record was found. You may still add the custom domain to your web app, but your web app will not receive any traffic until the correct A Record is created.

No, the @ symbol is meant to be expanded into your domain, that is not a problem.

Can you maybe share the domain for which you added the record? Best copy/paste it from Azure to make absolutely sure there are no typos in it.

1 Like

The custom domain is favpolls.com

That domain is currently proxied :norange:. For Azure to detect that you have created the record, you need to change it to DNS-only :ngrey: temporarily.

Oh. So I should change the CNAME record to DNS only? Which one? the www host or the _domainconnect

You say you created this record as DNS-only, but it is clearly proxied right now.

favpolls.com.           300     IN      A
favpolls.com.           300     IN      A
;; Received 73 bytes from in 4 ms

The domainconnect record should be DNS-only as well, and not only temporarily.

I don’t understand. The A record of the IP address from Azure is set to DNS only. How does it appear not to be for you?

Can you show a screenshot of what you see on https://dash.cloudflare.com/?to=/:account/:zone/dns/records ? Including the part about “Cloudflare Nameservers”?

You need to delete the other A records that you have. They show a GoDaddy parking page. As long as you have one proxied record for any given name, all records will be treated as proxied.

1 Like

Thanks that worked! But now the SSL from Cloudflare is no longer working for some reason (It is instead trying to use the one from Azure which doesn’t work since I don’t have the Azure Basic plan).

This is what it says:

This server couldn’t prove that it’s favpolls.com; its security certificate is from .azurewebsites.net . This may be caused by a misconfiguration or an attacker intercepting your connection.

Now that it works, you can enable the proxy again for that record.

However, you should understand that this does not activate SSL for your domain. Visitors will no longer see a warning, but the connection is still not encrypted.

You can use a free Origin certificate form Cloudflare to really activate SSL:

(The title says Full, but they actually use Full (strict).

1 Like

That works perfectly. Thank you!

1 Like

You might also want to delete the screenshot that shows your IP address now :wink:

1 Like

Oh right I forgot haha. Thanks again :smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.