DNS A record config is done but cant see propagation

So… I did the config of my DNS records and the propagation is not working correctly…

Initially the propagation didnt work for Brazil and using a proxy to the US we could see my domain working…

Then the propagation did work and the Load balancing was fully working and now the DNS is pointing again to Cloudflare ips…

It is pointing to 104.31.86.234 and 104.31.87.234…
And now I got Error 522 “Connection timed out”…

Wtf are u guys doing???
I came to Cloudflare because I thought u guys were the best players in the market and Im experiencing this problem…

WTF ARE U GUYS DOING?!

What is your website?

Error 522 is because Cloudflare is unable to connect to your origin server.

https://support.Cloudflare.com/hc/en-us/articles/200171906-Error-522-Connection-timed-out

The link is http://esapi.ml

The health check tells that the website is working, but the Cloudflare doesnt work…

And now it isnt giving me any response…

The website is http://esapi.ml

And now the domain isn’t even loading anything…
The health check is returning me that is everything fine…

Should I be turning CDN off and using only DNS?

EDIT:

My application DOESNT run ANYTHING in port 80. Do u think that Cloudflare is doing this because my server doesnt use port 80???

Which port are you using?

https://support.Cloudflare.com/hc/en-us/articles/200169156-Which-ports-will-Cloudflare-work-with-

1 Like

Im using port 6001

There is your issue in the article that @Withheld linked you can see that 6001 is not a supported port without Spectrum

1 Like

It should be working if I disable proxying?

Yes.
It will expose your IP to the public and won’t use Cloudflare’s CDN or other features.

1 Like

Yes it should. However I just checked and it appears that you’re still :orange: behind the proxy.

Yeah…

I did add a endpoint on port 2095 returning “server is ok!” and status 200 and also disabled the proxy more something like 16 minutes ago…

1 Like

Glad to hear it’s up. Have a great evening.

No, it isnt up as I expected… The proxy is down for more than 20 mins ago and i still cant access port 6001…

I did put the whole service running on 2095 as I cant wait anymore, but the proxy still on…

I’ll need to change a lot of applications to use the port 2095…
And the load balance was VERY slow as I was testing…

Proxy disabled since 11 pm from yesterday and port 6001 still being blocked…

Also, I got downtime when my server got down… I’m not happy with Cloudflare service :frowning:

PS: I’m using u guys load balancing