DNS 1.1.1.1 has no result for my domain

When I dig for A records using @1.1.1.1 I don’t get any records, but when I dig with @8.8.8.8 I get correct results

dig @1.1.1.1 any 0zxc.com

; <<>> DiG 9.10.6 <<>> @1.1.1.1 any 0zxc.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOTIMP, id: 11864
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1452
;; QUESTION SECTION:
;0zxc.com.			IN	ANY

;; Query time: 8 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Thu Jun 18 15:38:06 CEST 2020
;; MSG SIZE  rcvd: 37

Here are results from google DNS

dig @8.8.8.8 any 0zxc.com

; <<>> DiG 9.10.6 <<>> @8.8.8.8 any 0zxc.com

; (1 server found)

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2487

;; flags: qr rd ra; QUERY: 1, ANSWER: 8, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:

; EDNS: version: 0, flags:; udp: 512

;; QUESTION SECTION:

;0zxc.com. IN ANY

;; ANSWER SECTION:

0zxc.com. 92 IN A 192.168.6.198

0zxc.com. 21392 IN NS ns-1093.awsdns-08.org.

0zxc.com. 21392 IN NS ns-1969.awsdns-54.co.uk.

0zxc.com. 21392 IN NS ns-232.awsdns-29.com.

0zxc.com. 21392 IN NS ns-789.awsdns-34.net.

0zxc.com. 692 IN SOA ns-1969.awsdns-54.co.uk. awsdns-hostmaster.amazon.com. 1 7200 900 1209600 86400

0zxc.com. 92 IN MX 1 mail1.smtp99.com.

0zxc.com. 92 IN TXT "v=spf1 include:amazonses.com include:_spf.google.com mx:mail.0zxc.com/27 -all"

;; Query time: 21 msec

;; SERVER: 8.8.8.8#53(8.8.8.8)

;; WHEN: Thu Jun 18 15:37:58 CEST 2020

;; MSG SIZE rcvd: 370
1 Like