DKIM Settings


#1

I am having some major issues with DKIM. I am quite a newbie but am pretty technically minded and normally can work things out for myself but this has me stumped.

I use DJEP to auto send emails and I am having issues since the DKIM is not set. I Know I have to set DKIM on CloudFlare and I can access this via DNS and scroll down to the TXT entry for DKIM.

When I test this DKIM on dkimcore.org I am informed it is a bad DKIM. I can generate a new DKIM on the same site but it is continually marked as wrong here in Cloudflare. My email client is gmail.

Does someone have a foolproof description of what I am supposed to do, all the way from generation to activation in step by step descriptions? I am pretty sure I can get to grips with this and there is probably something very straight forward that I am missing but this is literally driving me mad!


#2

I may have lost you, but how are you generating the DKIM signatures? Only someone with the private keys used to sign the e-mails will be able to sign the e-mails - so if DJEP are the senders, they should support this. Are you having them generate the keys and then trying to add the resulting records to Cloudflare, and despite that, it fails?

If you don’t mind sharing the records as given by DJEP and your domain, we can verify in DNS that you’ve added them correctly on Cloudflare.

If the keys you generated the DKIM entries from are your own and not DJEP’s - DJEP can’t sign with them (that’s the whole point, only the owner of the keys who published their public equivalent over DNS is authenticated as having access to the domain and thus owning e-mails sent for it).

By the way many providers can just change the SMTP envelope so the “mail sent from” is them and not you (and still use your e-mail address), and then do DKIM for their own domain without your cooperation. Setting DKIM is only required if the service provider actually masquerades as you.


closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.