DKIM Record problem missing period

I’m trying to set up a custom email domain with iCloud+. The instructions are as floows for the DKIM record:

But when I enter that in Cloudfare, it consistently removes the “.” which causes it to fail to work properly. How can I get around this issue?

What makes you think so?

As in quite a few threads :wink: explained the trailing dot is by no means necessary. In your case I’d assume the actual issue will be that that CNAME record is proxied. Make sure it is :grey:.

1 Like

Um because… all the other records have propagated. Proxy is set to off.

image

What’s the domain?

Try this:
dig CNAME sig1._domainkey.example.com

You should see the trailing dot.

Though the trailing dot is not the issue :slight_smile:

That will be a broken DNS setup in one way or another. Make your pick, DNSSEC, record, propagation.

1 Like

So a couple of things to note that I should have included originally:

I have a working DKIM record for “domain.com” That is currently set to google apps domain and it is a TXT record. I am trying to set up a subdomain, “test.domain.com” on an Apple iCloud+ and it uses the CNAME approach above. I don’t know if I need to modify the initial DKIM record to allow the subdomain? Maybe that is the issue?

This is my first time setting up a separate email subdomain.

what
is
the
domain

Plus, the record will most likely have to be called sig1._domainkey.test.

1 Like

@sandro that was the ticket! Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.