DKIM record is set but my emails is not signed?

#1

Hi, I generated a dkim key using this tool https://dkimcore.org/tools/keys.html and added it as TXT record as following

v=DKIM1; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDMvxAJ9+Pf/xshyo9qkpL+bKdtxuvNHSaQJWsnXJ7sglA4eHac7OWa8+HOS+P+NZPhpN1vdFCpee0rWfDzINf0GISRbl5iR8L6wtbfzzg1W3LiLtGVt0V0Fy19782QXUZVnNapGpKpTH8+blK0s710en3Wjtz7eMG9UFHJBHGJCwIDAQAB

and my dmarc record as following

TXT
record name: _dmarc
v=DMARC1; p=none; rua=mailto:[email protected]; ruf=mailto:[email protected]; fo=1

and the record name is default._domainkey and i tried to test it using different online tools which says that teh dkim record is valid but when i sent emails to some email providers such as gmx it end in spam folder and the emails does not appear to be signed and the email header doesnt have DKIM signature which i think it may be the cause of the emails going to spam folder, so i was wondering how to fix that issue?

my domain name is "bon am ico"DOT"de

PS: Im using hostgator shared hosting and using the cpanel mail

Thanks

0 Likes

#2

The DKIM signature should be enabled with the email provider. It’s not a Cloudflare issue.

0 Likes

#3

Thanks for reply, i just though that by setting DKIM record that will enable the DKIM signature.
Do you think that its posible and common to get the DKIM signature enabled on a cpanel mail shared hosting or i will have to go to mass email provider like sendgrid or amazon SES etc…?

0 Likes

#4

It really depends on your mail provider. Some mail providers are actually good and keep up-to-date with email security (DKIM) stuffs, but others don’t often update since it costs them money with no immediate ROI.

If there’s no DKIM signing settings in your cpanel/mail admin/etc, I recommend opening a support ticket with your mail hosting provider. Otherwise, you might want to look into other better providers like GSuite or Office 365 (which do support email signing).

2 Likes

closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes